Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Replacing the transmission in my 78 Brat Have some questions


  • Please log in to reply
6 replies to this topic

#1 Subieguy

Subieguy

    Subaru on the brain!

  • Members
  • 915 posts
  • Paso Robles, California

Posted 12 November 2017 - 10:55 PM

The transmission in my 78 Brat has gone bad. I have no idea what is wrong with it but I have a replacement transmission for it. I really am just looking for some help with finding the correct oil seals for it. Specifically the oil seals where the axles mount to the transmission and back at the shifter. The usual chronic places where our transmissions leak. Also, is there anything I can buy for the shifter bushings? Thanks.

Richard



#2 moosens

moosens

    Vintage Subathusiast

  • Members
  • 1,864 posts
  • Bridgeport CT

Posted 13 November 2017 - 01:58 AM

Those were all available as of a couple of years ago. Probably can still score.

What was the tranny doing or not doing ?

#3 Subieguy

Subieguy

    Subaru on the brain!

  • Members
  • 915 posts
  • Paso Robles, California

Posted 13 November 2017 - 03:47 PM

The transmission just started making this strange grinding noise. I thought something was wrong with the left CV axle. It was going bad. I had a new replacement so, I changed it. Didn’t help at all. I put it up on jack stands so the front wheels were off the ground. I put it in first and it would not freely move the wheels without giving it a lot of gas. It vibrates really bad too. It shifts fine. Definitely not the clutch. Paul, you wouldn’t happen to know any of the part numbers for any of the oil seals I need would you?

#4 moosens

moosens

    Vintage Subathusiast

  • Members
  • 1,864 posts
  • Bridgeport CT

Posted 13 November 2017 - 06:23 PM

I feel like a knucklehead - typical - but I know I saved those numbers but where they are now is beyond me. I sure will try to locate them. Pretty sure I saved the receipt from the dealer.

Lots of guys seem to have the Factory parts manuals , and maybe even some posted online.
Mine are not handy at the moment.

#5 moosens

moosens

    Vintage Subathusiast

  • Members
  • 1,864 posts
  • Bridgeport CT

Posted 13 November 2017 - 06:28 PM

There’s at least two or three trannies here is you need one. All good , early top starter single range.
If you’re in a pinch I could send one.

Your description sounds like the differential but tough to tell.

#6 Jonv23

Jonv23

    USMB Regular

  • Members
  • PipPipPip
  • 104 posts
  • Muskegon MI

Posted 14 November 2017 - 07:47 AM

The transmission just started making this strange grinding noise. I thought something was wrong with the left CV axle. It was going bad. I had a new replacement so, I changed it. Didn’t help at all. I put it up on jack stands so the front wheels were off the ground. I put it in first and it would not freely move the wheels without giving it a lot of gas. It vibrates really bad too. It shifts fine. Definitely not the clutch. Paul, you wouldn’t happen to know any of the part numbers for any of the oil seals I need would you?

I have a factory parts manual in PDF form.  If you send me your email in a PM, I can try to email it to you.

For what it's worth, you can still find parts if you really scour.  I just bought a factory original, NOS 4 blade fan for my 79 BRAT.  It came out of the UK, but the parts are out there.



#7 Subieguy

Subieguy

    Subaru on the brain!

  • Members
  • 915 posts
  • Paso Robles, California

Posted 15 November 2017 - 12:49 AM

I have a 1979 Parts manual in PDF. It's just not clear on the oil seals for the transmission. In fact, I don't even see a picture of the ones that go where the axles mount to the transmission. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users