Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Windshield Washer Pump Replacement


  • Please log in to reply
4 replies to this topic

#1 Phugoid

Phugoid

    USMB Regular

  • Members
  • PipPipPip
  • 50 posts
  • St. Paul

Posted 24 March 2005 - 12:50 AM

Hi, I just found this site today and it's exactly what I was looking for. I just purchased a 97 Outback Limited and the windshield washer pump does not work. This is the front pump, not the rear. I'm planning to replace it this weekend and I was hoping to do it with a Subaru OEM part. The dealer quoted me $90 for this part. Am I being taken for a ride here?

NAPA says they have a "one size fits all makes" version for $20. Does anyone know if this part will fit in the stock location?

I searched the site pretty thoroughly for tips on how to troubleshoot and the replacement and I found some great info. The only question here is the part and maybe where to get it.

Thanks!
Reid

#2 frag

frag

    Soob shade tree mechanic

  • Members
  • 1,777 posts
  • Montréal, Québec, Can.

Posted 24 March 2005 - 10:05 AM

You can buy one (OEM) at 1stSubaruParts for 50$
https://www.1stsubar...m/partscat.html.
Dont know about the universal one.
Are you sure it's the pump and not the connector? Is there voltage getting to it?

#3 Phugoid

Phugoid

    USMB Regular

  • Members
  • PipPipPip
  • 50 posts
  • St. Paul

Posted 24 March 2005 - 10:43 AM

I'm not sure yet about the connector. Over the weekend, I'll get in there with a DMM and start checking things out.


Thanks for the link.

Reid

#4 gbhrps

gbhrps

    User Awaiting Email Confirmation

  • Members
  • 799 posts
  • canada

Posted 24 March 2005 - 06:46 PM

Phugoid,

Frag is most likely right! I'd check out the corrosion on the electrical connectors at the pump. They are the most frequent culprits.

#5 lmdew

lmdew

    _______

  • Members
  • 2,806 posts
  • Colorado Springs

Posted 24 March 2005 - 08:08 PM

Take some jumpers right from the battery. That will power the pump and if it still doesn't work, you know its the power. If you want a used subaru pump, there is a 98 in the yard. I can pull it for you. $20 shipped.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users