Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Still looking for the fuel-pump relay


  • Please log in to reply
4 replies to this topic

#1 jimbo747

jimbo747

    USMB Regular

  • Members
  • PipPipPip
  • 101 posts
  • Chandler, AZ

Posted 14 December 2003 - 01:21 PM

Skip posted earlier that I can find them "above and to the drivers side of the steering col. You must remove the trim panel to see them. "

O.K. I need some help here. Are we talking inside the engine compartment, or inside the car? Which trim panel do I need to remove? Help, Please!

#2 calebz

calebz

    Andys Coupe killed my cat

  • Administrator
  • 7,547 posts
  • Tacoma

Posted 14 December 2003 - 01:35 PM

Inside the car. its the trim panel right above your knees when you are sitting in the drivers seat. the fuel pump relay and ignition relay are directly above the left side of the ECU.

#3 jimbo747

jimbo747

    USMB Regular

  • Members
  • PipPipPip
  • 101 posts
  • Chandler, AZ

Posted 14 December 2003 - 02:05 PM

Thanks

#4 jimbo747

jimbo747

    USMB Regular

  • Members
  • PipPipPip
  • 101 posts
  • Chandler, AZ

Posted 20 December 2003 - 03:42 PM

One bit of advice that would have been helpful is the fact that I needed to drop the ECU.

After all this work, turns out the relay was fine. Still have know idea what the problem is (was, since the Loyale is starting and running fine, now). :confused:

#5 Skip

Skip

    Flatuous Blather

  • Moderator
  • 8,991 posts
  • Latrobe, Pennsylvania

Posted 20 December 2003 - 04:54 PM

Yes Jimbo good call, should have warned you,
some models you do have to drop the ECU (it's on U shaped open mounts so you can just loosen the three 12mm nuts)
Some models they are visable, sorry.
Hope it stays runnin'





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users