Jump to content
Ultimate Subaru Message Board

MDW

Members
  • Content count

    87
  • Joined

  • Last visited

  • Days Won

    2

MDW last won the day on November 3 2016

MDW had the most liked content!

Community Reputation

44 Excellent

About MDW

  • Rank
    Advanced Member
  • Birthday 12/28/1984

Contact Methods

  • Website URL
    http://michaeldwillis.tumblr.com

Profile Information

  • Gender
    Male
  • Location
    Grand Haven, Michigan
  • Interests
    Outdoors, Cooking, Fun
  • Occupation
    E-Commerce
  • Referral
    Mechanical_misfit
  • Vehicles
    91 Loyale, 86 Brat
  1. I am driving 5 hours to pick up a 78 Brat tomorrow. All I know is that is constantly blows fuses, which cuts power to the car. The person who owns it says he removed/broke the hazard switch and it has been blowing fuses ever since. I'm renting a car, so If I can not get this car running, I will be stranded. Sounds like fun right? Anyone have an issue like this? Anyone know what's going on? Are there workarounds? Anyone willing to be on call when I work on this thing tomorrow? Anyone who helps me fix it, I will buy a six pack beers!! Thanks Everyone.
  2. MDW

    83 GL10 Rupert

    I did some digging, and have found a few, as of right now I am not going to worry about it until I buy my house and have a garage I can heat. haha. plus it would be difficult to tear apart while at the campsite. I camp all year round so this will be a walk in the park, really excited for all the color. Discovered a powerstearing fluid leak today but that's no too serious for me, I will just fill it until I have time to tear into it again. I drove it for about an 1.5 hours today to the city to drop off my Rat at a friends house. The car rode so well, I am so happy with it, grinning ear to ear. The engine runs great Tom! thanks again!
  3. MDW

    83 GL10 Rupert

    First, Fievel wanted to say hi, and bye, he is living with a friend for a month while I am temporarily homeless. Second, I was able to score a Thermo Switch from @mechanical_misfit, and also scored a sweet set of white wagon wheels, picture to come. The Radiator fan is now operational!! The car is running so damn good I could not be happier. Still little things to tinker with, as always. But right now it's packed up and ready for my next adventure. I will be camping for the month of october while I wait for issues to be worked out with the house I am purchasing. Here is Rupert all Packed up for the adventure: Here is how well he blends with it's natural environment: Does anyone know what this fuse is to? The 20Amp fuse inside of this white enclosure? It is blown and I can't figure out what it goes to? ALSO the speedo, temp, RPM's and oil pressure are not showing up on my digital dash cluster, I need to do some research, anyone heard of this issue?
  4. MDW

    83 GL10 Rupert

    I drove it a little longer tonight to fill up the tires and gas it up. Running really really well! I could not be happier with the way it runs, currently. idling very well at a lower RPM, simplifying the Hitachi works so well. I pulled this carb from my brat, and it ran like spoob when it was on the brat. The re-build and de-smog worked wonders. Having all sorts of electrical issues right now. there is no thermo switch installed so the fan should be running, but it's not. I don't see a wire to connect the radiator to the radiator support, my brat doesn't have one either. Maybe this is the issue, but I am not missing a cable, at least I don't think I am. Where does the cable go? My blinkers are not working either. Was not able to check brake lights, because I could not see them while diving. Maybe I am missing a crucial ground somewhere. any ideas?
  5. MDW

    83 GL10 Rupert

    Never-mind found the answer to my question! haha
  6. MDW

    83 GL10 Rupert

    I will be working on them tonight I will have to do just that! good idea. My fan is not coming on, I do not have the sensor in the radiator yet, is this the sensor that triggers the fan? or is one of the sensors in the manifold the ones that triggers it? Thanks!
  7. MDW

    83 GL10 Rupert

    Thank You! I was pleased with the orange. I was hoping to work on it last night, but I am packing up my house. I did not close on the house I was supposed to by because Real Estate is a complicated mess of bureaucracy . I am homeless in 7 days so I have been furiously packing up my house, and moving everything into storage. I will leave the brakes as is for now, and focus on wiring up a temp heat gauge. Jimbo has a sensor I am going to steal from his parts car, thanks for the offer though! As far as the Ignition timing is concerned. I actually brought the flywheel to 8* and set the distributor so the rotor was pointing directly at it. The car wouldn't start and just shot a plum of smoke out of the carb. When I adjusted to about 30* it runs really well and and when I inch towards the 20* it stalls and dies. weird right? Could the flywheel be on wrong, because I did not pay attention to he markings when I put it on. (wasn't even thinking about it) I was going to drive it a little last night on the backroads to let her open up a little bit, but in the moving fury I have lost the key.... this might get interesting.
  8. MDW

    83 GL10 Rupert

    IT's ALIVE!! After tinkering for a while, discovering some loose ends and installing a new fuel pump, it finally came to life. Was able to drive around the block last night. It felt great to leave the driveway on Ruperts own 4 legs. Ran very rough, but tuning is in process. Current Issues: 1. Timing is no were near 8, currently off the charts at probably 30, I think this may be due to the current high RPM's it want's to sit at. I have tuned ignition timing by ear so far. If I bring it anywhere near 20 it stalls. 2. Runs okay, idle is pretty darn high, need to tinker more. Hitachi has been simplified and works great so far. 3. Missing sensor from Radiator, may hardwire fan to a switch for now so I can drive and not worry about traffic jams. 4. Dash cluster is fried, needs to be replaced but don't have time to rip it out. Will be researching wiring up an after market heat gauge, which is about all i need for now. 5. Pistons in front brake calipers will not turn at all, so I can't complete a break job, which it badly needs form sitting for 7 months. 6. The shifter want's to fall through the floor PRO's It runs. it look sexy, here are some pictures: SO MUCH FUN!!!
  9. MDW

    83 GL10 Rupert

    Why would I do something like that, the engine goes in the car not on the ground! That was a funny joke right? no...okay ill stop I actually did not ground the engine, but peaked into my brats engine bay to see a ground wire going to the engine. My starter was turning over the engine fine so I thought it has ground, did not know it needed a separate cable, but it does make sense since the engine sits on rubber mounts. I figured my issues are small ones like this, I am going to spend some time with the electrical diagram and fuel diagram this afternoon to make sure everything is right. I'm going to do some research on the carb rebuild to see what I could have possibly done wrong, It's all new parts, I have no idea why the bowl wont fill when the check valve is installed. I have a bad feeling that it's only the start of my fuel issues, but I have another hitachi that is acting as a donor, I could make that one work for the time being if needed.
  10. MDW

    83 GL10 Rupert

    Well it's been a long 4 days, multiple trips to the parts store, hardware store...you know the usual for putting an engine in a car. I have had a lot of fun and everything is in the car. of coarse it wont start. Gave up for the night will tackle it again tomorrow. Issues. at first the bowl was not filling with gas. I re-built my hitachi and i think something may be wrong with float. I unbolted the top of the carb, removed the float and cranked the engine over to see if gas was even entering carb. It just kind of slowly poured out. I bolted the carb back together with the float removed so the bowl would fill in an attempt to get gas into the engine. I believe gas is now flowing through carb, I can see gas getting into manifold, but no spark. I even tried spraying carb cleaner directly into the top of the carb, but no spark. I will do some detective work tomorrow to try and work these kinks out. I will take some pictures too.
  11. MDW

    83 GL10 Rupert

    What are the crucial bolts to be putting lock-tight on? What's the hard and fast rule on this?
  12. MDW

    83 GL10 Rupert

    Oh cool, thanks for letting em know. I'm assuming I will need a different bolt then for mounting my exhaust. Need to make a parts run anyways, and I'm sure I will make a few more parts runs this weekend when I find out everything else I'm forgetting, haha.
  13. MDW

    83 GL10 Rupert

    I do have a disty, I think we pulled several out, i did take one. I should be putting the Engine in tonight, getting parts tomorrow to complete the job. so we will see if It all works soon enough. I have high hopes.
  14. MDW

    83 GL10 Rupert

    It's actually the manifold I took out of Rupert when I got it. The EA82 is going in the Brat! What parts did we leave behind? I'm sure we will be back at some point, haha. Most likely no, I have been taking things out of the car and trying to simplify as much as possible. I love mechanical, may even be using a manual choke carb if I can't successfully rebuild this hitachi.
×