Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
LeRoyMarx

1995 Legacy L Upholstery shop F'd up my sunroof switch while replacing the headliner

Recommended Posts

So, on the recommendation of a friend, I had this shop redo my headliner. Sunroof control worked flawlessly before the work was done, now... es no worked. Oh well, I live, I learn.

 

No surprise, when I took it back he claimed that he didn't remove the switch or bezel (oh really, then how in the hell did you did you get godamm material underneath it!? Fucktard!).

His trouble shooting method was to repeatedly push the button forward and back as if he'd just pulled a ten inch rail of biker crank.

 

My question to ya'll is; how do I remove the bezel and switch, so that I can have a look at it myself. My specialty in auto care is limited to appearance restoration and maintenance (formerly known as detailing and car washing...we can get into that subject at another time if you'd like) and anything that requires no more than a socket set and screwdrivers. I'm iffy on interior trim...especially on older plastic trim parts.

 

Any Advice?

 

Thanks

Share this post


Link to post
Share on other sites

I have in the past removed the one in my 95.  Just from memory, easily done. thinking the lens pops off and then a couple of screws.  Good chance the sunroof is not working is its wiring harness is disconnected/the shop forgot to plug it back in. 

 

 

Just recalled there are 2 connectors. One is obvious. The other one is about 6 inches from the light, driver's side. You'll need to remove the visor and the headliner can be pulled back enough to gain access. My money is on this plug is the one the shop overlooked. 

Edited by john in KY

Share this post


Link to post
Share on other sites

LeroyMarx,

 

John in KY is correct. Pop out the lenses to the map lights, undo the screws that are now visible, and the entire unit drops down to where you can disconnect the wiring harnesses for the switch and the sunroof computer.

 

Then check the switch to see if it works with an continuity meter/light. Disconnect the harness from the sunroof computer to the motor and power the motor with 12 volts to see if the motor still works. Did you check for a sunroof fuse? Maybe the turkey shorted a wire to blow it, and its an easy fix. Providing the jerk didn't screw the wiring or connectors, you should find it to be simple to correct. Even if the switch is bad, you can clean it with an electrical contact cleaner spray sometimes. Dig into it, its not rocket science.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×