Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
TheSubaruJunkie

RX Wiper problems (very slow wipers)

Recommended Posts

Well... found problem #1 with the new RX. My wiper's aren't working propperly. Instead of having OFF-INTERMITTENT-SLOW-FAST, I have OFF-OFF-SLOW-SLOW. And when i mean slow, i mean sllllloooooow. Of course, i had to find out durring the rainfall, but I'm not even sure where to start looking. Would the problem be in the switch? Im not sure what would make the motor move so slow... anyone have any suggestions?

 

-Brian

Share this post


Link to post
Share on other sites

Under the dash, behind the kick panel (where the "lap cooler" vent is) there is a box, that is the intermittent relay for the wipers, it's probably unplugged, if it's plugged in, I'd suspect either the ground for the wiper motor, or the gear train in teh wiper motor is gummed up....

Share this post


Link to post
Share on other sites

100% agreement.

 

If that doesnt work...might try taking the motor assy apart and cleaning/relubing it and putting it abck together...

Share this post


Link to post
Share on other sites

Nice... MSN Message me and gimme a price. I think mines dead or dying cause now my intermittents are messing up. It will move the wiper about an inch then stop, and then another inch, then stop until the wipers are about 1/2 way, then they go and come back, then stop, another inch then stop, another inch then stop.

 

I'm gonna get a relay from the junkyard and see if maybe that might be it.

 

-Brian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×