Jump to content
Ultimate Subaru Message Board

Recommended Posts

went for a test drive after all the work i have done to my 95 subaru. replaced the right front cv axle but still clicks and clunks with acceleration and turning.

passenger says it feels like it is right at his feet. when install ing the axle i pulled the splines out inside the axle in the boot but it went back together fine. is this the problem. def sounds like drive axle but it is a brand new axle.....

AHHHHHHH!

Share this post


Link to post
Share on other sites

also the new axle feels like it has more play in it than the old one.

feels like a looser fit on the stub axle splines.

is there a break in period for the axles or something like this?

Share this post


Link to post
Share on other sites

you installed the spring pin?

axle nut is REALLY tight?

 

no, there is no break in period for an axle.

 

don't want to jump the gun and trash a good axle but there's a good chance the axle is junk because you bought an after market axle, right? spend some time reading here and you'll find after market axles suck. after having my own expeditions with aftermarket axles i now only use Subaru or MWE axles. i recommend you doing the same if it turns out this axle is bad.

Share this post


Link to post
Share on other sites

speaking of switching, you might already mean this - but you could switch sides since they're identical left to right and see if the vibration "moves", although it seems like you're fairly sure it's the axle anyway.

 

good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×