Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

I bought this EA82


  • Please log in to reply
51 replies to this topic

#51 Subaru Scott

Subaru Scott

    New User

  • Members
  • PipPipPip
  • 61 posts
  • Cape Coral, FL

Posted 09 November 2012 - 07:02 PM

You guys running without belt covers reminds me of a car I worked on while I was a dealership tech in the late 80's. Work order said "check coolant leak" so I pulled it in and left it running while I opened the hood, expecting to see a water pump drip. When I looked down I couldn't believe what I saw... customer had gotten the engine so hot the covers had melted off... yes, OFF!!! :headbang: Completely gone except for a few saggy strings of plastic still hanging here and there!! The thing still ran fine but I only replaced the pump and told him to drive it for awhile before replacing the covers to make sure the engine was ok... never saw him again.

Edited by Subaru Scott, 09 November 2012 - 07:06 PM.


#52 l75eya

l75eya

    Almost has it all figured out

  • Members
  • 1,741 posts
  • Hoboken, NJ

Posted 09 November 2012 - 07:39 PM

Posted Image



Haha! This is awesome. I'm allowed to say that because I did something similar driving around in the mountains in Utah by Bonneville.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users