Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

My WRX TMIC install pics.


  • Please log in to reply
14 replies to this topic

#1 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 07 December 2004 - 02:17 PM

Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image
Posted Image

Done. LOL

The spare tire mount...I took a sledge to it to flatten it down level with the rest of the spare tire area, otherwise the IC would be too far up in the engine bay and hte hood would not shut.

Thats my boost control solenoid mounted on the drivers side of the IC there incase anyone is wondering.

#2 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 6,872 posts
  • Oregon City

Posted 07 December 2004 - 02:28 PM

man I wish my turbo wasn't covered in oil..... Looking good except for the fact that it looks a little messy but hey, if it works, why f*** with it?:D Very nice!

#3 Vanislru

Vanislru

    Durka Durka!

  • Members
  • 791 posts
  • Cumberland, BC

Posted 07 December 2004 - 04:36 PM

Nice, got any footage of the BFH action? Scoop shot, did I miss it?

#4 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 07 December 2004 - 06:43 PM

No BFH action....next time I take the IC off, I'll pic it.

Scoop...look up some pics of my wagon, im using that hood...and its still blue/decaled right now.

#5 rallyruss

rallyruss

    Subaru Master

  • Members
  • 1,653 posts
  • San Jose CA

Posted 08 December 2004 - 01:23 AM

Will.... your crazy.

but hey your used to that by now.

I would be slightly concerned about the epoxy job for the bypass valve. I used the little muffler thingys spot. I also turned my IC side ways to avoid the unwanted use of a sledge on my car. I guess I should post a new pic as its changed a little bit since I last put it up. I will work on that when I get home from work.

#6 rallyruss

rallyruss

    Subaru Master

  • Members
  • 1,653 posts
  • San Jose CA

Posted 08 December 2004 - 04:04 AM

man I just got home took some good detail pics of my whole TD04 conversion and related mods. then I found the camera cable went to work with the wife.:banghead:

I was going to give Will a picture battle:D

I fabed a crazy bit of intercooler ducting/cold air inducting and took it out for a bit of a ride out of the hood and up a big hill climb with turns. It was raining a bit too. that made it fun. new tires stick great. felt realy strong.

ok sorry Will I will start my own thread of pics tomarow with explanations.

#7 Marck

Marck

    Certified Subaru Nut

  • Members
  • 776 posts
  • Nipomo

Posted 09 December 2004 - 12:14 PM

How did you mount the intercooler to the car?

#8 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 09 December 2004 - 05:13 PM

Me? its 'floating'

the piping is holding it on...plus the hood.

#9 Marck

Marck

    Certified Subaru Nut

  • Members
  • 776 posts
  • Nipomo

Posted 09 December 2004 - 05:30 PM

Are you planning on bolting it down because that is the part I am worried about when it is time to install mine? Does the intercooler move around alot when driving aggressively?

#10 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 09 December 2004 - 05:32 PM

not that I know if. seems to be fine.

#11 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 6,872 posts
  • Oregon City

Posted 09 December 2004 - 06:15 PM

yeah but still its a good idea to make a bracket, even if its just a little one to hold it down. Me? I'm currently making plans for a 3 point strut tower brace and a TMIC intercooler bracket....just need a WRX TMIC:banghead:

#12 Subi81

Subi81

    1000+ Super USER!

  • Members
  • 1,006 posts
  • Ventura, Ca

Posted 09 December 2004 - 06:17 PM

is that a hydralic line in there? was that a biproduct of the uppipe/downpipe install.

#13 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 09 December 2004 - 07:52 PM

is that a hydralic line in there? was that a biproduct of the uppipe/downpipe install.


Yes. PS lines. I need to get a longer return line to add a cooler in line...

#14 TheSubaruJunkie

TheSubaruJunkie

    I'M BAAAAAACK!

  • Members
  • 1,921 posts
  • Sacramento

Posted 10 December 2004 - 02:46 AM

Russ... you got those pix up yet? :)


-Brian

#15 rallyruss

rallyruss

    Subaru Master

  • Members
  • 1,653 posts
  • San Jose CA

Posted 10 December 2004 - 03:09 AM

Russ... you got those pix up yet? :)


-Brian


no :-\


not only is the little cable from the camera to the computer gone but the camera is MIA now too. I will sneak out to the car and see if she left it in there.

nope no good. oh well I have the battery charger held hostage. camera has to come home someday soon for a recharge. and when it does Im all over it.;)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users