Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

2005 Legacy 2.5i cruise control shuts off


  • Please log in to reply
11 replies to this topic

#1 banny

banny

    New User

  • Members
  • Pip
  • 1 posts
  • College Park

Posted 06 February 2006 - 04:02 PM

I have a 2005 Subaru Legacy 2.5i, 5-speed manual transmission. When I use cruise control, the cruise control will shut off sometimes. When I say "it shuts off", I mean it no longer keeps the speed I set it at and gas pedal is no longer depressed, but the "cruise" light is still on. So it's kind of like when you're in Cruise Control and you tap the brake, even though I didn't.
At first, I thought it was happening only when the engine exceeded 3k RPM but, but it seems it happens at slower speeds as well. Anyone else experience this problem?
Thanks.

#2 subeman90

subeman90

    Soobologist

  • Moderator
  • 2,779 posts
  • Akron PA

Posted 06 February 2006 - 05:10 PM

the first thing I would check if I was to work on it would be the brake (and also in this case clutch) switch. Maybe the tolerance is set too close and a bump in the road is enough to trip the switch. See if it happens when you hit bumps. Been down this road once in an 85 blazer years ago.

Otherwise...you got warranty...let them figure it out. :D

Matt

#3 hooziewhatsit

hooziewhatsit

    I fix old cars

  • Members
  • 1,333 posts
  • Klamath Falls

Posted 06 February 2006 - 06:25 PM

try searching at www.legacygt.com I know they have a similar problem listed over there.

#4 Setright

Setright

    Elite Master of the Subaru

  • Members
  • 3,176 posts
  • Denmark

Posted 07 February 2006 - 01:42 AM

Pulling the CC stalk toward you will cancel the setting, Maybe you are knocking it with your knee??

My 2006 Forester lights up the "Cruise" in the dash but also has a "Set" light that comes on when the computer has taken charge.

#5 nipper

nipper

    Semi Elite Master of the

  • Members
  • 17,546 posts
  • Long Island NY

Posted 07 February 2006 - 01:59 AM

I have a 2005 Subaru Legacy 2.5i, 5-speed manual transmission. When I use cruise control, the cruise control will shut off sometimes. When I say "it shuts off", I mean it no longer keeps the speed I set it at and gas pedal is no longer depressed, but the "cruise" light is still on. So it's kind of like when you're in Cruise Control and you tap the brake, even though I didn't.
At first, I thought it was happening only when the engine exceeded 3k RPM but, but it seems it happens at slower speeds as well. Anyone else experience this problem?
Thanks.


is there any pattern to it shutting off? Under any specific conditions?


nipper

#6 Legacy04

Legacy04

    New User

  • Members
  • PipPip
  • 19 posts
  • Boston

Posted 08 February 2006 - 08:48 AM

I just noticed the same thing on my 04 2.5. Seems to shut off when going up a very slight incline. Light stays lit, gas stops though. I think it's under warranty until 36K.

#7 Legacy04

Legacy04

    New User

  • Members
  • PipPip
  • 19 posts
  • Boston

Posted 08 February 2006 - 08:55 AM

Just spoke with the stealership & there was a recall on the unit.

#8 Juan

Juan

    USMB is life!

  • Members
  • 188 posts

Posted 09 February 2006 - 04:33 AM

[quote name='banny'] When I say "it shuts off", I mean it no longer keeps the speed I set it at and gas pedal is no longer depressed, QUOTE]

How can you tell if the gas pedal is depressed?

Juan

#9 rcoaster

rcoaster

    H6 Power!

  • Members
  • 502 posts
  • Rochester, NY

Posted 09 February 2006 - 06:09 AM

When I say "it shuts off", I mean it no longer keeps the speed I set it at and gas pedal is no longer depressed,


How can you tell if the gas pedal is depressed?

Juan


Yeah, I was wondering too because the 2005's are "fly by wire" systems. Your gas pedal doesn't have the throttle cable but a potentiometer attached to it which in turn, controls a servomotor on the throttle plate. You don't have the feedback with cable actuated systems. My 2004's crusie control is a fly by wire system, but still uses the actuator cables, so I do get the feedback.

#10 Legacy04

Legacy04

    New User

  • Members
  • PipPip
  • 19 posts
  • Boston

Posted 09 February 2006 - 09:00 AM

Dropped off car last eve, and stealer called me this AM saying there was NO recall, but it will be fixed under warranty.

#11 Zephyr

Zephyr

    USMB is life!

  • Members
  • 127 posts
  • Kansas City, Kansas USA

Posted 09 February 2006 - 10:10 AM

Dropped off car last eve, and stealer called me this AM saying there was NO recall, but it will be fixed under warranty.


software update?

#12 Legacy04

Legacy04

    New User

  • Members
  • PipPip
  • 19 posts
  • Boston

Posted 09 March 2006 - 09:54 PM

New computer so they say.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users