Jump to content

Search the Community

Showing results for tags 'short circuit'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 2 results

  1. hey all, I recently acquired a 1990 legacy. Drove it for a couple days, then all of a sudden I'm driving along and all of a sudden the car dies instantly with all electrical gone. Checked the battery and alternator and both are good. Tracked it down to the fusible link in the underhood fuse box, which had blown. So i grabbed another one, put it in and as soon as i hooked the battery up it blew up. Pulled all the fuses in the box, put in another and smoked it too. So i'm at a loss. I'm new to Subaru's, anyone have electrical issues like this before? I don't know what would be upstream of the fuse panel that, with all fuses removed, would be smoking this fusible link like that. Any help would be appreciated, thanks!
  2. Hello, Is this a common problem with a common fix? Does anyone know the reason for this? The 15 amp fuse that keeps blowing out is for ECC, Room, Stop. Stop is the brakes, Room is the interior, so what is ECC? I thought to look at the brake pedal switch, but dont know where it is.
×