Jump to content
Ultimate Subaru Message Board

Recommended Posts

ok I checked the ECU codes on my 87 GL-10 and heres what I got

11-crank angle Sensor or circuit

13-Crank angle sensor or circuit. why is there two diff codes for the same thing?

14-fuel injector-abnormal output

21-coolant temperature sensor or circuit

24-air control valve or circuit

31-Throttle sensor or circuit. Is this the TPS?

34-EGR solenoid or circuit

35-purge control solenoid or circuit

42-idle switch or circuit

so how do I check these out? I'm hoping Skip sees this

Share this post


Link to post
Share on other sites

does the car run at all? that many codes tells me you have a power/ground problem. start by checking your referance voltage(5v) and ground at an easy location. you can do it as the under dash connector if im not mistaken. or at the tps if you dont want to look it up.

Share this post


Link to post
Share on other sites

Hey JWX

 

I checked the codes on my ’87 RX this weekend (found out the “check engine light” was missing and the PO was running with the test mode connectors plugged in :rolleyes: ). I got three, O2 sensor, idle switch and neutral switch (does the 5 speed even have one??) I cleared the codes and have been running for 4 day and still no codes.

 

I’d say clear them first, if it’s a real problem it will pop back up soon. The FSM has procedures to check all the components.

 

Gary

 

P.S. I thought the test mode connection was suppose to lock out the timing advance but with the timing light on it, it would still advance from idle (dose it have mechanical advance?), and the car seems to run the same with them disconnected.

Share this post


Link to post
Share on other sites

Now the Russ mentioned it, I also cleaned and reconnected my main ground cable and body-to-trans ground wire this weekend too.

Gary

Share this post


Link to post
Share on other sites

I also need help with codes on my 1987, but with a carb. I've read the how-to page and I'm still confused.

 

I can't find the connectors to activate any of the modes. There are no orphan connectors under the hood and around the pedals there are only two lonely connectors, but both are female. One's red, the other yellow. Near the firewall in the engine compartment, on the driver's side, there is a six pin female connector.

 

There is no oxygen sensor, the cat has a threaded plug in it. Without an oxygen monitoring unit with an LED on it, who will I read the codes? The how-to page lists codes for an 1987 with carb so I'm assuming codes are being generated/stored.

 

Also, I need to find an antibackfire valve.

 

Thanks,

XR

Share this post


Link to post
Share on other sites

referance voltage check

 

I assume you have acess to a wire diagram?

if not look for the round conector on the tps. it has three wires. ground, 5v ref, and the tps signal. black, red, and white. black is ground, red is signal, and white is 5v ref.

 

use a volt meter and have fun. if you get stuck let me know.

XR4- 87 carb with no o2 is eiter modified and codes will do you no good or never had a o2 and therefore no codes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×