Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

1987 fuel problem or is it electric

help

  • Please log in to reply
7 replies to this topic

#1 stillmarykay

stillmarykay

    Newbie

  • Members
  • Pip
  • 4 posts
  • Upton, Wy

Posted 16 June 2014 - 04:29 PM

1987 Subaru gl  we have gone through the fuel system, new pump, new filters, rebuilt carb.   It just won't keep running, like its not getting enough fuel.  Won't rev up.  Like its not getting enough gas.  Help



#2 naru

naru

    1000+ Super USER!

  • Members
  • 1,774 posts
  • under the bridge

Posted 16 June 2014 - 05:41 PM

Check for plugged exhaust.



#3 stillmarykay

stillmarykay

    Newbie

  • Members
  • Pip
  • 4 posts
  • Upton, Wy

Posted 16 June 2014 - 08:36 PM

Thanks for the idea we checked the exhaust and it is not plugged.  I keep thinking its not fuel, we checked spark and that is all good.  Keep trying open to any and all other suggestions.



#4 skishop69

skishop69

    If it ain't broke, you're not trying.

  • Members
  • 908 posts
  • Puyallup

Posted 16 June 2014 - 09:07 PM

EA82 I assume? Have you checked the timing belt to make sure it hasn't slipped? Timing? Carb'd or FI?  Compression test?



#5 stillmarykay

stillmarykay

    Newbie

  • Members
  • Pip
  • 4 posts
  • Upton, Wy

Posted 16 June 2014 - 09:42 PM

Thanks, you say EA82 , now this is my son's Subaru we have been unsure if it is a 87 or 88.  His title says 88 but it was built in 12/87.  So how do I tell and what is a EA82?  Thanks so much for any and all help you can give us. 



#6 wagonist

wagonist

    User Awaiting Email Confirmation

  • Members
  • 441 posts
  • Sydney, Australia

Posted 16 June 2014 - 10:22 PM

Have you checked whether the fuel lines are blocked?



#7 two85s

two85s

    New User

  • Members
  • PipPipPip
  • 68 posts
  • San Diego County

Posted 16 June 2014 - 10:24 PM

I have a 85 gl 4WD dual range wagon.   It has "EA82" large and stamped in the metal of the engine.  It is located in front of the carburator approx in the middle of the engine, behind a plastic "cover plate"on my car.  THe EA82 stamp may be covered with grime, grease, etc.  I had a similar problem to what you are describing and I did many of the "fixes" you have done.  Almost by accident I found my problem was a vacuum line cap to an unused tube had been knocked or fell off.  Once I capped the open tube off....bang the engine came back strong.  There are many very knowledgeable Subaru experts on the USMB. Aaron



#8 skishop69

skishop69

    If it ain't broke, you're not trying.

  • Members
  • 908 posts
  • Puyallup

Posted 17 June 2014 - 09:39 AM

EA82 is the engine type. They have plastic timing belt covers on the front of the engine. EA81 engines have no timing belt.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users