Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

new to site


  • Please log in to reply
6 replies to this topic

#1 Leeco

Leeco

    New User

  • Members
  • Pip
  • 2 posts
  • montrose colo.

Posted 05 August 2004 - 09:58 AM

I have recently acquired a 1979 brat in need of several parts inluding tail lights, front parking light lens etc. unfortunatly I must also deal with a good amount of rust. My immediate problem is that the engine will not start without spraying "engine starter in the carb and then it will only idle. when I push th gas pedal it dies. help?

#2 Sweet82

Sweet82

    Elite Master of the Subaru

  • Members
  • 3,266 posts
  • Salt Lake City

Posted 05 August 2004 - 10:45 AM

Welcome to the board!

Have you tried several gallons of carb cleaner?:rolleyes:

I'd think about getting some fresh gas and fuel filters too.....

Has the Brat been sitting a while? What is the history of this Brat?

Glenn
82 SubaruHummer
01 Forester

#3 Leeco

Leeco

    New User

  • Members
  • Pip
  • 2 posts
  • montrose colo.

Posted 07 August 2004 - 11:00 AM

Welcome to the board!

Have you tried several gallons of carb cleaner?:rolleyes:

I'd think about getting some fresh gas and fuel filters too.....

Has the Brat been sitting a while? What is the history of this Brat?

Glenn
82 SubaruHummer
01 Forester

The brat had been sitting for 4 years/changed gas and filter/ blew air thru feed line from filter to tank/ used carb cleaner and now it at least starts and runs with hesitation on acceleration/ now the plugs etc. thanks for the reply.

#4 mons72

mons72

    USMB Regular

  • Members
  • PipPipPip
  • 69 posts
  • mo i rana

Posted 07 August 2004 - 11:50 AM

welcome to you:)

#5 sparkster58

sparkster58

    1000+ Super USER!

  • Members
  • 1,141 posts
  • Alki-West Seattle

Posted 07 August 2004 - 01:37 PM

:banana: welcome ....this is a great place and everybody is great

spark

#6 subyrally

subyrally

    Trust your Turbo-Lust

  • Members
  • 2,888 posts
  • frederick, md

Posted 07 August 2004 - 02:15 PM

welcome to the board, you are lucky to have a brat

#7 DeathHatch

DeathHatch

    USMB is life!

  • Members
  • 160 posts
  • Puyallup

Posted 07 August 2004 - 02:39 PM

welcome to the board. you should find anything you need here.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users