Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

I need help...turn signals


  • Please log in to reply
7 replies to this topic

#1 Hogsubie

Hogsubie

    Eat, Live, Breath Subaru

  • Members
  • 266 posts
  • Northwest Arkansas

Posted 28 January 2004 - 03:53 PM

I have an 81 dl wagon and today at lunch my turn signals stop signalling. I have a solid turn indicator on the dash when I turn it either direction. On most cars I know that they flash double time when you have a blown bulb, but I've never experienced this.

Does anyone know what's wrong? Is it just a fuse? I wouldn't think I'd get anything at all if it was a fuse. Blown bulb? Thanks.

#2 rallyruss

rallyruss

    Subaru Master

  • Members
  • 1,653 posts
  • San Jose CA

Posted 28 January 2004 - 04:10 PM

sounds like a flasher. the lights come on and no blinky right? easy one to fix.

#3 Sweet82

Sweet82

    Elite Master of the Subaru

  • Members
  • 3,266 posts
  • Salt Lake City

Posted 28 January 2004 - 04:16 PM

Nobody around here uses turn signals............

Maybe they have the same problem you do?

Hummm..............;)

#4 heartless

heartless

    Do YOU Subaru?

  • Members
  • 2,855 posts
  • North Central Wisconsin

Posted 28 January 2004 - 04:34 PM

well, first I would turn on the signal, and get out and check the bulbs....if all bulbs are lit, then it is probably the flasher unit.
process of elimination. :rolleyes:

#5 rallyruss

rallyruss

    Subaru Master

  • Members
  • 1,653 posts
  • San Jose CA

Posted 28 January 2004 - 04:35 PM

no they cant use turn signals, talk on the phone and drink thier non fat tripple whip chi tea latte at the same time either.:mad:

looking in the mirrors also proves to be dificult under these circumstances.

#6 ru4x4ever

ru4x4ever

    Eat, Live, Breath Subaru

  • Members
  • 349 posts
  • Medford, Oregon

Posted 28 January 2004 - 04:38 PM

Its the relay under the dash!!! I just hade the same problem last week and i replaced the relay and wow my flashers work!!
-Sean:cool:

#7 junkyardgabe

junkyardgabe

    WRX Goal Accomplished!

  • Members
  • 558 posts
  • Lisbon Falls

Posted 28 January 2004 - 04:56 PM

if you have to take the flasher from your hazard light to get by with

#8 Hogsubie

Hogsubie

    Eat, Live, Breath Subaru

  • Members
  • 266 posts
  • Northwest Arkansas

Posted 28 January 2004 - 05:23 PM

Thanks guys. I didn't have a chance to actually look at the lights outside yet, had to get back to work. I'll have to check those tonight. Nobody uses their turn signals around here either, even the police! And if they do use them, they leave 'em on for miles and miles.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users