Jump to content
Ultimate Subaru Message Board
Kevint143

My 79 Brat build

Recommended Posts

gonna call the guy at the subaru wrecking yard..he probably has one. But if anyone else does please let me know!

he only works monday-friday incase you dont know that. i really hate that because thats only time i can ever go his way:banghead:but his parts prices are really high you could buy some of the stuff from subaru for what he wants.

Share this post


Link to post
Share on other sites

Yea last time I was there he said he is open mon-fri and Sunday by appointment only or if you call his cell number that's on his business card

Share this post


Link to post
Share on other sites

I was driving out on Sandy here in Portland and spotted this gen 2 so I pulled over and took some pics hoping the owner would come out! anyone know it? It had stickers on the back window and on the tailgate a sticker that said heavy metal.

 

8327116125_d669980063.jpg

Was driving towards gresham today and look what I found! #subarubrat #subaru #soobielove by Kevin Talley, on Flickr

Share this post


Link to post
Share on other sites

i think i might know him did the seats look like they came out of another newer car? and did it have washington plates? i swapped canopys with him once if that fits the discription and he lives in seatle/tacoma

Share this post


Link to post
Share on other sites

Nice go with the plasti dip. I'll be doing that to my entire brat next couple of months, until I have enough $$ to lay some good paint on it.

Share this post


Link to post
Share on other sites

I need help!!!!

 

I was driving home and my car started idling super high in Neutral so i pulled over and checked it out..I found the source and am confused on what to do now...It appears to be a vacuum leak so I called a friend who is a car guy but not sure about old subarus and he said just plug it with something until you get home and take it easy since I had my 3yo with me and we were about 15mins from home. Well i covered it with electrical tape and made the drive home the idle returned to normal but it started to get jumpy in 3rd and 4th kinda felt like it was going to stall but kept going. Now since I have no idea how to explain it I took some pictures and maybe you can help..I looked through my repair manuals and the only picture I can find that has this valve doesn't have a description or anything so Please help if you can.

 

8343764147_1784908b42_n.jpg

Untitled by Kevin Talley, on Flickr

 

8343765175_a7e60ce72d_n.jpg

Untitled by Kevin Talley, on Flickr

 

Thanks in advanced for any help. ANd I have not removed anything this is exactly how it looked as I opened the hood.

Share this post


Link to post
Share on other sites

look for hoses not hooked up and see if you can find where it goes. if that port doesn't go anywhere cap it and put a hose clamp on it so it doesn't leak. and hook up that loose hose i cant tell if it goes on that other port or not from this angle. what manual do you have? i looked in my factory ones and couldn't find that port so i will look at a couple ea71's tomarrow.

Share this post


Link to post
Share on other sites

I can't find any hoses that are disconnected. But like I said that other picture looks like it just has a cap over it of some sort..maybe it came off or cracked or something?

Share this post


Link to post
Share on other sites
I can't find any hoses that are disconnected. But like I said that other picture looks like it just has a cap over it of some sort..maybe it came off or cracked or something?

probably got old and split then flew off from it having pressure on it.

Share this post


Link to post
Share on other sites

So today I found where my brake booster is routed so just plugged that vacuum port up for the time being. I also installed a new Accelerator Cable and man does it feel better, and while I was at it I messed around with the idle ajust screw to get a better idle. My Tach is reading about 500 rpm while idling does that seem about right? I just went with what sounded good.

 

8351930768_4deba448d8.jpg

Another present for the brat by Kevin Talley, on Flickr

Share this post


Link to post
Share on other sites

Yeah I had a friend send a picture of his brat over to me and my line from the master cylinder goes into a different vacuum port so i just capped this one off for now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×