Jump to content
Ultimate Subaru Message Board

Recommended Posts

Aright so ej swap has been on the road for 25k miles, then it starts normal one morning, shut it off for a few hours, go to take off again and it just cranks and trys to start soo bad, it sounded like a low idle  while cranking, but nothing. It has spark and fuel too, the spark looks bright yellow? I got towed around the block with it in gear, it did nothing but spudder here and there. I replaced the cam/crank sensors, the ignitor, coil, and plugs and nothing. I jumped the main relay and also squeezed the fuel return to build higher fuel pressure incase the regulator crapped out.


I also got another harness and ecu, tryed the ecu first, same result. Now I just got done spending like 12hours on the new harness, and put it in the car and the SAME crap. The main ground for the ecu is good and snug. I pulled the side timing cover and wiggled the belt and it's tight, i couldn't possibly see it slipping.

BTW before doing all this I pulled codes and got idle switch, iac, neutral sw, and st. switch. none of these seem like they would threaten it starting at all? I also hooked the start switch up this time.


 Also The only ground is through the harness and to the intake manifold, for the ecu that is, but that worked before.


Link to comment
Share on other sites

i didnt test it, the belt has about 10k and its a gates brand, it was tight though, I didnt get the cover off to check it, but I might tomarrow. If that doesnt work im gonna try another engine harness, that should eliminate all the posibilties, hopefully

Link to comment
Share on other sites

I checked the t-belt and it's fine and timed and replaced the engine harness, still no start except it may start and run for maybe 2-3 seconds and die.

I checked codes, its only 23 (maf sensor) due to me unplugging to try starting fluid, and with starting fluid it fires right up and stalls like "no fuel", yet it flooded so bad that there is a puddle of gas out from the exhaust.


So I pulled the plugs and they weren't soaked, but totally black with carbon, (these were new plugs.)

I unplugged all injectors and disabled ignition and spun it around a few times and let it sit to dry out, tryed cleaning plugs, hooked everything up, and STILL ISN'T STARTING!


With the green test connectors hooked up and the pump cycling I can for sure hear fuel moving through the rail, so obviously I would think It has enough pressure, as it's pushing through the regulator.


This Is day 4 of trying to fix this and its driving me nuts!!!

Link to comment
Share on other sites

A puddle of gas would not come out of the tailpipe. That's just water.


If the plugs are carbon fouled you should remove them and clean them at the very least. New plugs would be better but might just foul again.


So you're gettin fuel, the question is how much? Low fuel pressure can still carbon foul the plugs if the injector spray pattern is weak.

High fuel pressure sprays too much fuel.


Still think you need to put a gauge on it and check fuel pressure.

Link to comment
Share on other sites

As it turns out I didn't fully check my t-belt right, I judged it by just the cam wheels, I lined up the crank and the cams were like 5 teeth off!, anyways I fixed that and It starts right up, but stalls like its outta gas after about 5 seconds at idle, or instantly if I touch the gas. I remember it doing this once before when the IACV was disconnected, but It isn't

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...