Jump to content
Ultimate Subaru Message Board

Electrical Issues After Replacing Blower Motor on 2004 Outback

Recommended Posts

Yesterday I removed the blower motor for diagnostics and replaced its relay near the in-cabin fuse box of my 2004 Outback Limited. Replacing the relay solved the problem with the blower motor.

When putting the blower motor back in place, however, I had to really pull and mush on a large mass of wires that runs directly below the blower motor. It was not a simple task to take the motor out or put it back due to this large group of wires (roughly 1-2 inches in diameter) running right under the blower motor with very little room to budge. 

Immediately after getting the motor back in position, my car would not start and the fuel pump relay would buzz madly with the key in ignition. The stereo receiver died and the lights on the dash were dying. After turning my car off, a part under the hood began to buzz and all the electrical equipment began to rhythmically click and turn on/off. I disconnected the battery and went to bed.

I messed something up when getting the blower motor back in. I pulled wires loose or damaged them. The wires branch off after passing the blower motor, some running to the blower and the rest running up the passenger side of the car.

When getting the motor back in I pulled on a small black circle with three little holes in it, above where the passenger would rest his feet. It appeared to feed into the group of wires and run out to the engine compartment. Maybe this is important.


Any information regarding troubleshooting or what could be wrong with my car would be very helpful. Thank you.


Attached are pictures of items I mentioned in the post: the fuel pump relay, the part under the hood that buzzes, the group of wires under the blower motor, and the black circle with the three holes in it.






Edited by Chago54
Link to comment
Share on other sites



Your pictures show a black and a white connector on the right side of the first photo that are not connected. Did you reconnect them?


If that doesn't do it, you have stretched the harness wires and connectors, and either broken a wire or two, or have pulled a wire or two from its pin inside the plastic harness connectors.


Try pushing the harness connectors back together again. Try starting the car afterwards. Still no go ..... you'll have to take each connector and ensure connectivity between the wire going into the connector and its respective pin with a multi meter, by probing each wire and its pin for continuity.


If that still gets you nowhere, you'll need a good mechanic, or an automotive electrical shop to get to the bottom of the issue.


By the way, those black plastic plugs are anchors for that main wiring harness. The plugs have straps that are taped to the wiring harness to keep it up out of the way of your feet. Nothing fancy there, unless you yanked on them breaking a wire or two inside the harness. Good Luck!

Link to comment
Share on other sites

Those 00-04 Outback blower motors are absolutely stupid for this reason. You basically have to break something to remove them. I feel your pain.


What symptoms did you have that the relay fixed?


Clicking and buzzing all speak to dead battery or poor connections. Have you absolutely verified it's seeing solid voltage?


I would start simple and look at any and every wire harness you worked around. Look for any adjacent connectors or sharp turning points.

Edited by grossgary
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...