Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
pappy52

EA82 cranks,no start-prime,run quit

Recommended Posts

I was checking a friends 1992 EA82 SPFI for water loss problem. After running for 1/2 hour I shut it off. Went to restart and it wouldn't. I saw the gas gauge read empty. I put in 2 gallons and tried again. No go. I primed the TB and it fired, then died. Tried several times, same thing. Question is, if the tank was totally dry, do I need more gas to make sure the intake is covered, or will this pump "suck air" and pull the fuel up. Seems the relay is clicking as it should.

 

ides? Answers?

 

Thanks, Jon

Share this post


Link to post
Share on other sites
I was checking a friends 1992 EA82 SPFI for water loss problem. After running for 1/2 hour I shut it off. Went to restart and it wouldn't. I saw the gas gauge read empty. I put in 2 gallons and tried again. No go. I primed the TB and it fired, then died. Tried several times, same thing. Question is, if the tank was totally dry, do I need more gas to make sure the intake is covered, or will this pump "suck air" and pull the fuel up. Seems the relay is clicking as it should.

 

ides? Answers?

 

Thanks, Jon

 

Sounds like air lock in the fuel injection system to me. I've never run a fuel injected gas engine out of fuel, but I know that for diesels, it can take several hours work to restart them if you run them out of fuel.... Might have to crack the fuel line at the throttle body to let the air out.

Share this post


Link to post
Share on other sites
I was checking a friends 1992 EA82 SPFI for water loss problem. After running for 1/2 hour I shut it off. Went to restart and it wouldn't. I saw the gas gauge read empty. I put in 2 gallons and tried again. No go. I primed the TB and it fired, then died. Tried several times, same thing. Question is, if the tank was totally dry, do I need more gas to make sure the intake is covered, or will this pump "suck air" and pull the fuel up. Seems the relay is clicking as it should.

 

ides? Answers?

 

Thanks, Jon

 

DO you hear the eletric fuel pump running? The fuel serves two purposes, the obvious one, and to keep the fuel pump cool. Make sure the fuel pump has power, and stick your ear next to it, or make sure you have flow. COuld be an air pocket, but thats not usually a probelm with a gasoline engine.

 

nipper

Share this post


Link to post
Share on other sites
DO you hear the eletric fuel pump running? The fuel serves two purposes, the obvious one, and to keep the fuel pump cool. Make sure the fuel pump has power, and stick your ear next to it, or make sure you have flow. COuld be an air pocket, but thats not usually a probelm with a gasoline engine.

 

nipper

 

No noise. I tried it with a "known good" pump and still no noise. Question- am I correct in saying that the fuel pump should run all the time, with the excess fuel returning to the tank by return, as in a diesel? If so, I should be able to check the relay at the LW wire on the 5-wire test connector-right?

 

thanks, Jon

Share this post


Link to post
Share on other sites

It will not run all the time, it should run for 1-2sec. when U turn the key on but then it will stop untill the engine fires and then it should run all the time. I just delt with an SPFI EA82 that ran out of gas, just turned the key on and off a few times to get the sys. re-primed and that's all it needed. I would check to make sure that the fule pump is geting power at all.

Share this post


Link to post
Share on other sites
It will not run all the time, it should run for 1-2sec. when U turn the key on but then it will stop untill the engine fires and then it should run all the time. I just delt with an SPFI EA82 that ran out of gas, just turned the key on and off a few times to get the sys. re-primed and that's all it needed. I would check to make sure that the fule pump is geting power at all.

 

OK finally got myself organized, so this will be long. the car I am working on is a 92. I have an 88. When I go to the "start" position on the 88 I get heavy clicking and growl from pump. On the 92 at "start" I get no growl and light clicking that now I see corresponds with the tach needle bouncing off it's max stop. I haven't been able to get my boat hook and coat hangers configured properly to turn key to start while at pump. (Ran out of duct tape). I think it comes down to bad relay, huh?

 

Appreciate all the help.

 

Jon

Share this post


Link to post
Share on other sites

What U need is a testing tool that I made a few years ago (after toooo long trying to test stuff like this alone) Get an automotive horn, and 2 lengths of wire (about 20" each) and 2 aligator clips. Put it all together and U have a hands free test horn insted of a test light. Then hook that up to the wires for the fule pump, sit back and turn the key to "start" and see if the horn sounds:) If it does, then U know that the relay is good;)

Share this post


Link to post
Share on other sites
What U need is a testing tool that I made a few years ago (after toooo long trying to test stuff like this alone) Get an automotive horn, and 2 lengths of wire (about 20" each) and 2 aligator clips. Put it all together and U have a hands free test horn insted of a test light. Then hook that up to the wires for the fule pump, sit back and turn the key to "start" and see if the horn sounds:) If it does, then U know that the relay is good;)

 

Great idea! I got the relay out, no problem. I am going to my doner (also a 92)car and get the one out of it. I am also going to cut the pump connector from it for future test us. While I am there and have it apart, is the ecu box (doner 92) the same or interchangable into an 88? Lately I am the local Subaru guru. (Lonely up here)

 

My 88, Scooter, is my daily driver. Bought new, now 245000 mi. Also have '96 Outback. Previously had '79 GLF, and '84 Hatch. Love 'em all.

 

Thanks, Jon

Share this post


Link to post
Share on other sites
While I am there and have it apart, is the ecu box (doner 92) the same or interchangable into an 88? Lately I am the local Subaru guru. (Lonely up here)

Thanks, Jon

Don't know on that, I'm not so hot with the ECU's and such. Some one else is sure to the awser here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×