Jump to content
Ultimate Subaru Message Board

Recommended Posts

would a bad fuseable link cause wipers to stop working, then a few miles down the road work fine, ? + rear wiper + cig lighter , or something else, ? thanks

Share this post


Link to post
Share on other sites

there is a fuse inside the engines compartment fuse box that is for the dome lights, cig lighter, radio etc, that fuse got me by surprise, i did not know that fuse would control so many things... its just a regular fuse... i think a 20a

Share this post


Link to post
Share on other sites

Once a link goes bad it doesn't repair itself. They can have a intermittent connection though and cause things to work intermittently. Links carry a good amount of current and supply power to a lot of things tied to them.

Share this post


Link to post
Share on other sites

ok, i blew a fuseable link about a year ago, not thinking , i used one from a ea82 motor, and i can not remember the color or which place i put it in, also something else strange, my speedometer is working fine now, no bouncing around the fuel gauge is still reads less than whats in the tank, where is all the ground wires at, iam sure there is more than 1, . 95 legacy L awd a/t 2.2 motor,with 165,000mi on it,

Share this post


Link to post
Share on other sites

Fuel tank is a subaru thing (and happens on other cars too). You need to remove the senders and clean them with a hard pencil eraser (tried a soft one, it didnt work),

 

The wiper can be a bad internal switch in the wiper motor, or a bad ground. Run a new grounbd for the motor and see if it works first, Of course there is the possability that you have it on intermitent.

 

 

nipper

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×