Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
AWD95

HELP! Electrical probs/95leg/bad coil,ignitor or ECU

Recommended Posts

The Car: 95 LegacySW AWD/ABS 5 spd. w/61k

 

Problem: It will turn over but won't start

 

When it happened: I had just started it and it was idling for maybe one or two minutes with headlights on. I just released the e-brake and was pushing in on the clutch and finding reverse(simultaneously)and everything went dead, then the lights came on. So I tried to start it again and it turned over but did not start.

 

1)I've tested the secondary resistance on the coil pack-ok

 

2)I've tried to test the ignitor voltage but I don't believe I had the correct LED tester. I just have one with a normal tiny light bulb.

 

3) I'm getting about 12 volts from the center wire on the connector that goes to the coil pack connector.

 

4)According to Haynes the primary resistance on the coil pack should be .62-.76 and I'm getting 1.5

 

Anybody have any probs like this or with the ignitor, ECU, coil pack????

 

Is there a way to test the ignitor all by itself with a digital meter??

 

Please help-I'm lost or at least perplexed

Share this post


Link to post
Share on other sites

Did you get any CEL's?

 

Pull the plugs, see if they're wet with fuel. Hold them up against the block and see if they spark. If they don't, look at your electrical system, which you sound like you're doing.

 

If the coil pack is out of spec, then it's most like bad. I don't know what coil pack you have, but this should be the same for which ever one you have http://www.main.experiencetherave.com:8080/subaru_manual_scans/FSM_Scans/coilpacktest.jpg

 

If it's way out of spec, then it's probably bad. The link I gave also says how to check ignitor.

 

See what testing these pieces tell you and go from there.

Share this post


Link to post
Share on other sites

This is not my area of expertise, but.... Timing belt??? Had it happen to me before and it would turn and turn but not start.

 

Just a thought?????

 

95 Leg timing belt replace is recommended at 60K.

Share this post


Link to post
Share on other sites

Checked a few more things-

 

no cel's

all sensors are ok(cam/Crank)

no spark from plug to body

plugs aren't wet

 

 

I'm throwing in the towel and going to get a scanner!

 

I'll post as soon as i know anything

 

Thanks for all your help

Share this post


Link to post
Share on other sites

ok did the scanner test.....and nothing.... The autoxray ezread 2000 model scanner says "vehicle is not responding"

 

What does that mean??? I tried 2 different obd2 connectors as well as generic and specific on the scanner and the same result.

 

Is there a special connector?? The scanner says 1996 and later obd2 but mine is 1995 with obd2??

Share this post


Link to post
Share on other sites

Problem solved!

 

The scanner wasn't reading anything because a fuse "SBK2 or 3" was blown. Which is where my problem was. When I was pressing on the gas my foot touched some wires that touched another electrical connection(yellow) which in turn blew the fuse. FYI- these wires are located directly above the gas pedal(used to solve problems/diagnostics

 

I had checked everything top to bottom, mine vs. new parts, everything and nowhere in any book did it say that this fuse was related to the ignition system but it was in a round about way.

 

So I thank you all but especially Legacy777 for leading me in the right direction and posting a link to endwrench.com(which is where I found the answer in the archives under electrical)

 

ALL YOU GUYS ARE AWESOME!!!

 

Thanks again, check your wires, carry an extra fuse-they're $9.00 from the dealer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×