Jump to content
Skubaskott

Ea81 spfi swap help again. Coil. Fuel pump.

Recommended Posts

I have an 82 brat I am swapping to Fuel injection using @GeneralDisorder guide. I have everything in place and wired up. My issues are as follows.

I am only getting 6 volts at the coil. And I'm not getting any spark.

My fuel pump works. But only shoots fuel when it is hard wired. It won't turn on in test mode. Nor when I crank it I don't think.

The ecu blinks at me when my key is in on which is a good thing I think And the engine turns over.

I have looked and read, then looked and read, then looked and read again through the guide and my harness and I really believe I have everything hooked up correctly. Minus the neutral switch and cel wire.  

Any any any help would be Uber appreciated!!!

Share this post


Link to post
Share on other sites

What voltage at either side of the coil fuse and IGN terminal of ignition switch?

What voltage at the coil if you remove all wires from coil negative?(key on)

Share this post


Link to post
Share on other sites
26 minutes ago, naru2 said:

What voltage at either side of the coil fuse and IGN terminal of ignition switch?

What voltage at the coil if you remove all wires from coil negative?(key on)

I get zero when I remove the neg side. I'm getting 12 at what I bielve is the fuse

Share this post


Link to post
Share on other sites

12V on BOTH sides of the fuse?

Fuse is 4th from the right on the bottom row and labelled "ignition coil" on my 84.

If you have 12v on both sides,then there is no connection between the fuse and the coil.

Share this post


Link to post
Share on other sites
21 minutes ago, naru2 said:

12V on BOTH sides of the fuse?

Fuse is 4th from the right on the bottom row and labelled "ignition coil" on my 84.

If you have 12v on both sides,then there is no connection between the fuse and the coil.

Doe stage brat tach wire run through that fuse

Share this post


Link to post
Share on other sites

The only wire I have with the swa

4 hours ago, naru2 said:

Yes,both power and signal.

The only wire I have with the swap that could run through the brat fuse box and the harness is the tach wire.

Share this post


Link to post
Share on other sites

So your conversion uses the coil wiring from the brat or the donor loom? 

Is the fuel pump powered through the beat loom or the donor loom? It should be powered by the ECU which takes its triggers from the optical dizzy from the donor vehicle. If this is kaput, you need another dizzy. I have no idea how to check these things  

Cheers 

Bennie

Share this post


Link to post
Share on other sites

The conversion uses the donor harness. Donor disty. Donor coil. Donor ecu. Donor fuel pump. Everything from the donor car is powered through the donor car ecu. 

  • Like 1

Share this post


Link to post
Share on other sites

I have figured out if I give power from the battery straight to the coil. Everything works. Though the fuel pump im thinking is shooting to much fuel like it's not shutting off at all. The brat will start and idle for about 2 seconds before dieing unless I give it Gas.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×