Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

EA82 Cruise Control


  • Please log in to reply
16 replies to this topic

#1 kabarakh

kabarakh

    USMB Regular

  • Gold Subscribers
  • PipPipPip
  • 124 posts
  • Bellingham

Posted 27 December 2011 - 11:06 PM

Just wondering what everyone's thoughts were about adding cruise control to an '88 GL, is it worth the hassle? It's pretty much the only thing my Subi doesn't have that I'd really like it to have.

Anyone have any tips or part numbers?

Anything I should know?

#2 ihscout54

ihscout54

    Subaru Fanatic!

  • Members
  • 476 posts
  • Prescott, AZ

Posted 28 December 2011 - 10:08 AM

Not the answers your looking for but heres my .02 on this.
Ive looked into using EA82 cruise on my BRAT befor, but what ruined it for me was my EA81 wagon w/cruise. The manual trans + hilly local terrain, combo made it kinda useless. If you have an auto (and more H.P.) I bet its not too bad. Do some searching of the USMB, as I found info on this. The parts are available at the J.Y. and that will be your best bet.

#3 Cyfun

Cyfun

    Mud Baby

  • Members
  • 410 posts
  • Billings, MT

Posted 28 December 2011 - 10:56 AM

It's not too difficult, just gotta find a parts car. There were two kinds of cruise: factory installed and dealer installed. One had the cruise buttons on the steering wheel below the horn, the other had the buttons to the left of the wheel over by the rear defrost buttons.

Just gotta steal those buttons, wiring, control module, and the throttle actuator, I believe. There are a few threads on this lying around.

#4 kabarakh

kabarakh

    USMB Regular

  • Gold Subscribers
  • PipPipPip
  • 124 posts
  • Bellingham

Posted 28 December 2011 - 05:49 PM

It's not too difficult, just gotta find a parts car. There were two kinds of cruise: factory installed and dealer installed. One had the cruise buttons on the steering wheel below the horn, the other had the buttons to the left of the wheel over by the rear defrost buttons.

Just gotta steal those buttons, wiring, control module, and the throttle actuator, I believe. There are a few threads on this lying around.


Cool, yeah I've found a few threads on it, but nothing really definitive. Appreciate the input, I'll see whats available at my local pick&pull. Just wasn't sure what I'd be getting myself into :-p

#5 kabarakh

kabarakh

    USMB Regular

  • Gold Subscribers
  • PipPipPip
  • 124 posts
  • Bellingham

Posted 31 December 2011 - 10:15 PM

Ok, spent the day at a pick and pull getting some accessories for the car, but wasn't able to find any cruise control modules.

Anyone have one laying around that they'd like to part with? I do have the power mirror option, not sure if that means I need the factory or dealer option, I know that one will work and one won't lol.

Alternatively I was poking around the internet and found this

http://www.amazon.co...l/dp/B00029WQTW

Universal cruise control system apparently. Any thoughts on that?

Thanks again for any and all input!

#6 Flowmastered87GL

Flowmastered87GL

    WCSS Drunk

  • Members
  • 6,087 posts
  • Portland, Oregon

Posted 01 January 2012 - 07:56 PM

The car lacks power so much that I would never bother with it personally.

#7 eulogious

eulogious

    Inspiring Subaneer

  • Members
  • 1,090 posts
  • Olympia, WA

Posted 01 January 2012 - 11:14 PM

I just sold my spare cruise unit. They aren't difficult to install or use. I didn't mind mine when I had my wagon, used it all the time. Worked great. Ask in the wanted section of the classifieds, you might get lucky!

When looking in the yard, look for a GL-10 or a turbo, usually those both had cruise units in them. But beware, the factory cruise unit is a lot more involved then the dealer installed version. I have just played with the dealer installed unit...

Good luck!

#8 6 Star

6 Star

    Boxer Nostalgic

  • Members
  • 981 posts
  • South Seattle, WA

Posted 02 January 2012 - 01:00 AM

Interesting... A while back I picked up a '86 gl wagon for parts. It has cruise in it. :eek:
It doesn't work... But it is there. What trim levels did the cruise come in? Is it limited to turbo or gl10? This car (had) an ea82 (put in another vehicle) not a ea82t. Doesn't have any of the gl10 trim and the title says GL.

Anywho, I could get pics of it in the morning if people are intrested. :)
Like I said, its not working, and I think I want to hang onto it. It would just be an educational thing. :lol:

#9 kabarakh

kabarakh

    USMB Regular

  • Gold Subscribers
  • PipPipPip
  • 124 posts
  • Bellingham

Posted 02 January 2012 - 02:26 PM

Anywho, I could get pics of it in the morning if people are intrested. :)
Like I said, its not working, and I think I want to hang onto it. It would just be an educational thing. :lol:


I'd love to see some pics, and from the research I've done since I started this thread It shouldn't be too terribly hard to get it working, seems like a pretty simple system. Just gotta find all the pieces :brow:

#10 6 Star

6 Star

    Boxer Nostalgic

  • Members
  • 981 posts
  • South Seattle, WA

Posted 02 January 2012 - 02:44 PM

Ask and you shall recieve. :lol:
My camara just kinda sucks on closeups. :-\

Car is a '86 gl wagon, 5 speed dual range 4wd.

The controller inside the car.
Nevermind the red switch, that was for some lights the p.o installed.
Posted Image

And here is the (brain?) in the engine compartment.
Posted Image

#11 kabarakh

kabarakh

    USMB Regular

  • Gold Subscribers
  • PipPipPip
  • 124 posts
  • Bellingham

Posted 02 January 2012 - 03:16 PM

Awesome pics thanks! At least now I kind of know what I'm looking for under the hood:clap:

#12 bigjimd

bigjimd

    USMB is life!

  • Members
  • 209 posts
  • Petersburg, Va.

Posted 02 January 2012 - 07:50 PM

That pic is of an aftermarket type unit for sure. Early 80's Volvos used the same type unit on their cars. Might be easy to adapt.

#13 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 6,847 posts
  • Oregon City

Posted 02 January 2012 - 08:57 PM

I have a complete cruise kit from my '87 GL and I will see if there's a part number on it. It had a large black ball bolted to the passenger side strut tower, buttons on the steering wheel, brain behind the driver side kick panel, and the electrical harness was a plug and play, like a dealer install option. I will try and get some pics when the weather lets up.

#14 Skylar

Skylar

    USMB is life!

  • Members
  • 395 posts
  • Puyallup, Wa

Posted 09 January 2012 - 11:43 PM

It's not too difficult, just gotta find a parts car. There were two kinds of cruise: factory installed and dealer installed. One had the cruise buttons on the steering wheel below the horn, the other had the buttons to the left of the wheel over by the rear defrost buttons.

Just gotta steal those buttons, wiring, control module, and the throttle actuator, I believe. There are a few threads on this lying around.


I have an 88 gl spfi 5sp and my cruise isnt working.

I have buttons on the steering wheel that say " set coast " and the other one says "resume" i think . But i also have the button that says cruise under the rear defrost button .

So do i have a dealer installed or factory installed lol ? I'd like to get it fixed cause when im on the freeway im usually taking a long trip and my foot starts killing me !

#15 Caboobaroo

Caboobaroo

    USMB Drunk

  • Members
  • 6,847 posts
  • Oregon City

Posted 10 January 2012 - 02:21 PM

Should be the dealer installed cruise. If its not working, make sure the vacuum chamber under the hood (will be a big black ball bolted to the passengt side strut tower) and if it does, you might want to check the clock spring under the steering wheel.

And since I gotten 3 PMs so far, no I am not going to sell my cruise control setup! Its getting installed in my RX currently.

#16 Skylar

Skylar

    USMB is life!

  • Members
  • 395 posts
  • Puyallup, Wa

Posted 10 January 2012 - 08:12 PM

Should be the dealer installed cruise. If its not working, make sure the vacuum chamber under the hood (will be a big black ball bolted to the passengt side strut tower) and if it does, you might want to check the clock spring under the steering wheel.

And since I gotten 3 PMs so far, no I am not going to sell my cruise control setup! Its getting installed in my RX currently.


And if it does what ? Lol

#17 kanurys

kanurys

    High Altitude GL

  • Members
  • 689 posts
  • Durango, CO

Posted 11 January 2012 - 12:33 AM

My 87 gl has factory cruise. Its great on the flats and down hill. It is worthless on any sort of incline. I can't wait till I finish my EJ swap to see how it works. I'll snap some pics for you tomorrow.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users