Jump to content

Search the Community

Showing results for tags 'actuator'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 2 results

  1. The actuator for the vent system on my 1997 Brighton Legacy wagon has died and I am desperately looking for a replacement. My local Subaru dealer as well as my local mechanic have not been able to help so far. Does anyone have any suggestions? The mechanic is afraid if I keep driving on it, the door to the vent will fly off and damage something else.
  2. Iv'e had my AT 99 outback sport for a year now and when I first got it I had to jiggle the cruise control set lever to get it to set. After a while it would just shut itself off and not come back on. Increasingly it didn't want to come on, and now wont come on at all. I've checked the vacuum hose and its fine, taken the lever out and took it apart to clean the contact points, replaced the main CC switch, and checked to make sure the plastic plunger of the break switch was still there and all the parts are fine. I'll be checking the continuity of the actuator and break switch tomorrow but i would really like some input as to if anyone has dealt with this before. I have a 1,700 mile trip this thursday and CC would make it soooo much better!
×