Jump to content
Ultimate Subaru Message Board
1982gl4

My 1991 Turbo legacy, and a trip

Recommended Posts

Well I found a pre facelift sedan on bbs, the only problem was it was across the country. I've been looking for one for these for the last few years, and I made the decision to bite the bullet and make one heck of a trip across the country.

 

Last friday I took a bus to Boston with my Dad, and then a plane to portland. A day later (after visiting the evergreen air and space museum) Here are some pics of that,

 

1_zpsc16bc152.jpg

 

2_zpsf3f2de47.jpg

 

A giant carburetor from the spruce goose

3_zps0cdf89ca.jpg

 

6_zpse25976a3.jpg

 

Felt so nice to see green grass again!

13_zps07dc33a2.jpg

 

I purchased the car from a forum member and and started driving home later that day, the small oil leak, turned out to be not so small, and we were loosing about a quart every 100 miles or so. So we went to an autozone planing on fixing it the driveway when we started talking to this really cool VW owner, and he offered his garage to us! So in Grants Pass Oregon Dad and I fixed the leaking oil cooler.

 

 

15_zps4c53be67.jpg

 

16_zpsc71d361c.jpg

 

California!

19_zps07eedf21.jpg

 

We drove along rt 199 into the redwood forest, and then 299 into redding california which were two of the most amazing roads I have driven in my life, they were absolutely amazing both as far as view goes, and the roads were the super curvy canyon roads, unfortunately I don't have any pics of the roads as I was focused mostly on driving, but I do have some pics of the car in several places along the roads.

 

20_zpsb766aea9.jpg

 

23_zps0722871e.jpg

 

The Pacific

24_zpsbc140208.jpg

 

26_zps3c38258d.jpg

Edited by 1982gl4
  • Like 3

Share this post


Link to post
Share on other sites
This is the point where we started running into some pretty crazy weather due to the storm walda that was taking up most of the country. Outside of Redding we ran into snow! This became a problem as the tires that came with the car were sketchy at best.... Other wise this would have not bothered me at all being from the northeast I'm used to snow, and bad driving conditions.

 

28_zps213b93de.jpg

 

30_zps97ad18ab.jpg

 

And as we started going south it got worse, it looked like this for most of the time were were driving from Redding to Reno 

 

29_zps31e22dbb.jpg

 

And then outside of Vegas, sandstorms, some of them mixed with snow. This was about the time one of the tires gave up as well, the old tires couldn't take the constant 80mph and one of the belts in the LF gave up causing it to shake at lower speeds.

32_zpse5ac193a.jpg

 

34_zps269a4ad8.jpg

 

By the time we got to the Hoover Dam things started to clear up. What an amazing place this is you could actually hear the power lines. 

35_zps1e7c3097.jpg

 

37_zpsdddc2528.jpg

 

 

The next day in Flagstaff AZ we got some more weather, I also broke down and got new tires to get me home, the last road trip I took I lost 3, I wasn't going to let that happen, so after talking to the guy at the front desk I found anderson tire was a good local place. 

 

40_zpsc8011b8d.jpg

 

41_zpsf48882b0.jpg

 

 

Everything went pretty smooth minus some more rain and snow until we got into texas, where it started to get super windy, and we had some crazy sand storms.

42_zps6d0507be.jpg

 

After that there was some ice, rain, more ice, cars, trucks, campers upside-down off the road everywhere but I gave up taking photos at this point as I was trying to get home, the next real stop was seeing our friend in Tennessee who has a pretty cool collection of cars now. Including his now two oner Lincoln Continental 

 

45_zpsf92251d9.jpg

And his honda ruckus 

46_zps65f4ad9d.jpg

 

After that my dad and I drove home in a day. We put on 4410 miles in a week, and the car was great except a few small issues, now I just need to sell off some of my fleet so I can start building it up!
  • Like 2

Share this post


Link to post
Share on other sites


I brought this to work today, and got to do some maintenance, and swap out some broken/worn stuff that has driven me crazy over the lask 4k. First off I changed all of the fluids, including the brake fluid, and clutch master fluid. All of them looked pretty good, with the exception of the gear oil in the trans, it was pretty nasty looking, it was also over filled by a decent amount. 

1_zps37ac9374.jpg
New stuff!

2_zps9c307128.jpg

I also changed out all of the filters good thing I did, the air filter took a beating in the sand storms
All of the stuff next to it is the sand that came out of it... 
3_zpsf9cba473.jpg

I also washed it, inside and out, and pulled some of the stickers off, I left the Oregon state on in the rear quarter windowsmile.png
She cleans up pretty well. 
4_zps31bc9e24.jpg

I also did my first mod to it! I gave the rear taillights the same treatment as my wagon, I will say it is much easier to do on a sedan, I didn't even have to bake them! 
Before 


5_zps2ad418ba.jpg
 
After
6_zps3618a34b.jpg


I also swapped out my seat belts, as one of them no longer retracted, swapped a couple of trim pieces out of my parts car and changed out the shift knob for a non worn out one.
 
  • Like 2

Share this post


Link to post
Share on other sites
Changed the valve cover gaskets, they actually looked fairly new, but the drivers side was leaking pretty good, the bottom of the head was all oil, and the up pipe was getting a pretty decent amount of it too. I also cleaned the valve covers while I was there. It basically made me had where I live, just a little scrubbing in the parts washer and they looked like new, if the car had been here it's whole life they would have been very corroded, like the ones on my other car... 

 

1_zpsd7b3312c.jpg

 

I also replaced some of the very hard and brittle pvc lines with some silicon based hoses I had at work. 

 

2_zpsca418b70.jpg

 

Up next I need to figure out what the check engine light comes on for occasionally, maybe tomorrow night. The abs light is also on, but I think that system may not be around a lot longer, never cared for abs, it just has a bad history of being a garage door killer at my house... 
  • Like 1

Share this post


Link to post
Share on other sites

Thanks, I really like this car so far! We live in Vermont, we drove from 5 a.m. to almost 10 p.m, it was a pretty long day, but it felt nice to have a weekend at home to get out of road trip mode. 

Share this post


Link to post
Share on other sites

Thanks guys! 

 

I ordered up some parts for this, a few of them came in today. I have a new wiper linkage as this one is very worn due to it's north west life. I also got a new cts and knock sensor for it. I also ordered up some jdm parking lights. I can not wait for those to come in. I also hope to get my prodrives on this weekend! 

Share this post


Link to post
Share on other sites
Got to work on this some today! I swapped out my new wiper linkage, so nice to have that not hitting on the a pillar every time I turn them on. 

1-119_zpsbc4e6b4e.jpg

 

the worn section of the old one. 

2-67_zps13fad349.jpg

 

Swapped on my prodrives today as well, the car is a bit low for how wide they are though, and now they rub on the fenders both front a rear. I'm not sure what I'm going to do about it yet. I may roll the fenders, but I kind of have a thing against that. I may see if I can run a slightly smaller tire or something. Anyways it looks great with them. 

5-25_zpseef4d078.jpg

 

6-20_zpscce8f29e.jpg

Share this post


Link to post
Share on other sites

Sold my wrx yesterday so I can fund this project, and put most of it towards my house fund, so someday I can have a place of my own. But the remaining money went into this! I ordered new sway bars front and rear, links, bushings, and rack bushings all from whiteline. I also ordered a new steering wheel, master cylinder brace, and a boost gauge for now. I'll be ordering some more parts as I sell off my audi, and vw. 

Share this post


Link to post
Share on other sites

I think it was the right move, I like it because it is something you don't see very often ( I can't recall ever seeing one here that was more than a parts car). Plus I like driving it a lot more, even if the wrx was faster and newer, it just didn't have the same feel as this. 

Share this post


Link to post
Share on other sites

Seems really strange to see a turbo Legacy with no IC. All the ones here in NZ have the WAIC, or have been retrofitted with AAIC. I've never actually seen one without an IC before; I didn't know Subaru ever made a non-IC Legacy. Nice find though; unmolested first-gens are getting rare even here in the home of JDM. :P

Share this post


Link to post
Share on other sites

Seems really strange to see a turbo Legacy with no IC. All the ones here in NZ have the WAIC, or have been retrofitted with AAIC. I've never actually seen one without an IC before; I didn't know Subaru ever made a non-IC Legacy. Nice find though; unmolested first-gens are getting rare even here in the home of JDM. :P

None of them had an IC here. But it's a very popular and worth while upgrade and I'm sure this one will be seeing one on the future!

Share this post


Link to post
Share on other sites

Exactly what bratman said, our legacy turbos never had them. It could use one for sure. I don't know which way I'll go, I'm thinking front mount right now, due to the other engine modifications I have planed. I have another 2.2t I'll be pulling out of my parts car to rebuild with all new internals at some point, so that engine will need one when I'm finished with it. 

Share this post


Link to post
Share on other sites

Definitely front mount. And I know a guy you could ask about the what fits best too if you wanted, as he has done a few already. Can't wait to see it progress!

Share this post


Link to post
Share on other sites

Was his pre or post face lift? The preface lifts are a bit harder to add one as there is not as much room, I'll have to take some measurements and see what works best for it. If done well they can look very nice. 

This is basically what I'm going for. 

 

wcssx028.jpg

Edited by 1982gl4
  • Like 1

Share this post


Link to post
Share on other sites

It's not that them bumpers are hugely different, it's the fact that the 91's front end is a lot shorter, I think by almost 2" so there's a lot less space. I'' figure it out when the time comes.

 

Tonight I got something in the mail for it! I've been waiting for these for a couple of weeks now. 

 

 
1_zps1a6a3e1d.jpg
 
New (to me) jdm turn signals! I also hooked up the parking lights correctly for the edm's. Right now the lights I just got are not hooked up to anything, but I think I may turn them into turn signals, as that's what they would have been overseas. 
 
3_zps69d67439.jpg
 
2_zpsfb0a8065.jpg
 
4_zps9f9e171b.jpg
 
I also picked up a vf34, and a few other things for it this weekend. The rack bushings just showed up too, so tomorrow I'll be putting those in! 

Share this post


Link to post
Share on other sites
Today I de snorkused my car, some said it made more turbo noises, but I really didn't notice a difference. I made it from some threaded pipe, exhaust tubing, and some steel brake lines all welded together. came out pretty decent. 

 

1_zpsdde7bfec.jpg

 

I also got my whiteline endlinks in, and then realized I can't use them without swapping out the rear control arms, but I think I have a set so it shouldn't be a big deal. If not I can come up with a mount. I also got some new speakers in. 

Share this post


Link to post
Share on other sites

Good Grief.  You flew from Vermont to Portland, OR to buy a used car?   You're hard core.  I complain if I have to drive to Portland to look at a car.   Not many Subies in Tillamook... mostly farmers and loggers driving American and Toyota respectively.  

How'd you like all the green out here?   We just harvested our silage for dairy cattle feed on May 1st.  Grass was 3' tall.

Share this post


Link to post
Share on other sites

My subaru obsession does sometimes get the best of me, but it was a great trip, both my dad and I had a great time. I did enjoy the green, our grass is still dead. This is the first warm week we have had so far this year ( we consider warm about 50* this time of year haha) 

 

 

Got some more parts in today! New momo wheel came in, master cylinder brace, and a boost gauge. I love ordering a lot of parts all at once. Swaybars were shipped today as well, those are what I'm waiting for the most.  That and the momo hub so I can have the new wheel! 
 
Pics
 
1_zps59117560.jpg
 
2_zps72fc1fc0.jpg
Edited by 1982gl4

Share this post


Link to post
Share on other sites
Got my momo hub adaptor in. Installed the wheel this afternoon. I have to say it is a bit smaller than I was expecting, but I think I'll grow to like it. I also got my rear sway bar mounts in, all I need now are the sway bars, and I also need to get my rear control arms off from my GT wagon parts car so I can mount them. 

 

1_zpsae869b04.jpg

 

2_zps406f0fd0.jpg

 

I've also decided I don't like my boost gauge in its current location, I may make a gauge pod to replace the center dash vent, or below the radio, I like the dash vent idea, as I'd like it to be as visible as possible 

 

The gauge also has a peak and hold function, so I can see what my maximum boost has been. 


1_zpsd27989e9.jpg

 

Share this post


Link to post
Share on other sites
Got my rear sway bar installed tonight, as the rear links I was missing came in yesterday! Went very well, the car is so rust free both of the giant bolts in the rear hubs came right out, along with all the other bolts. The car handles very well now, and is super enjoyable to drive. It is a bit stiffer, but not annoyingly so. However it seems to be rubbing more in the rear now for whatever reason. I need to order strut spacers this weekend, I'm just trying to figure out which rear mount my car has... 

 

For whatever reason photobucket will not let me upload more than just this photo of the front sway. So here it is for now. I'll add some more of the rear when I can. 

 

3_zps8da7a618.jpg

 

 

Now i just have to fixed the rubbing issues, and I also have to get some brakes, my rear pads are super thin.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×