Jump to content
Ultimate Subaru Message Board
Sir_wankel

83 GL Won't start. SOS subie noobie

Recommended Posts

So I recently traded my Honda xr250 for a low mile 83 GL. Owner said it ran before it sat for a few months. 

To cut to the chase. Checked ignition, checked fuel. car will crank but won't start. Even changed the fluids, and spark plugs. The carb just seems to spit fuel out of the carb vents. Previous owner put a Holley on it. Figured it may have been the carb so got a new Weber 32/36. Put it on and still spits with no start. Now I'm thinking I need to adjust valve clearences since the service manual says that it may throw compression tests off. Should I get ready to crack open the valve covers, or should I focus my attention elsewhere? Any help should narrow it down, I'm new to Subaru flat 4s, so go easy on me. Thanks all!

Share this post


Link to post
Share on other sites

start with the easy stuff.  ...sounds like you have fuel. 

-does the distributor rotor turn when you crank the engine ?

-do you have spark at the plugs ?

- are the plugs wired in the right order ?

-check compression, see what you get. can't hurt

Share this post


Link to post
Share on other sites

Is the choke closed when it's cold?

From one of the earlier posts, you said it was pouring fuel into the intake?  It's badly flooded.  It takes a long time to clear that.

Give it a 2 second shot of carburetor cleaner in the primary, holding the throttle open.  Then go give it a crank, holding the gas pedal about half way down.  If it fires momentarily, you know everything is ok except lack of fuel / or mix.

 

 

Edited by DaveT

Share this post


Link to post
Share on other sites

Can you do a compression test before fiddling with valve clearances?

Tell us what firing order you have checked.

 

Share this post


Link to post
Share on other sites

Thanks guys for the tips. @ebarb @jono @DaveT @Dee2. Had a friend of mine who's good with older cars look at it. Seems that the distributor was firing in the wrong order. Moved it a few teeth and aligned with tdc and it turned right over! 

  • Like 2

Share this post


Link to post
Share on other sites

Feedback is what we like . Nice looking old beast. Is the colour the same as your bike or some optical digital illusion?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×