Jump to content

ThatSubaruKid

Members
  • Content count

    111
  • Joined

  • Last visited

Community Reputation

3 Neutral

About ThatSubaruKid

  • Rank
    New User
  • Birthday 07/20/1994

Profile Information

  • Gender
    Not Telling
  • Location
    Vancouver, WA
  • Interests
    Working on my Legacy and taking it out to play
  • Occupation
    Detailer/High School Student
  • Vehicles
    1990 Subaru Legacy Wagon
  1. Gag! Phone twitching. What I meant to say was. To google!
  2. Just putting this out there as far as crash/rollover safety goes, my buddy rolled his 1995 Legacy Wagon 8 times on a 350 yard stretch of I5 in California after being side swiped and over correcting. Three people in the car, one laying in the back seat without a seat belt and no major injuries. Just cuts from the shattered glass everywhere.
  3. Just putting this out there as far as crash/rollover safety goes, my buddy rolled his 1995 Legacy Wagon 8 times on a 350 yard stretch of I5 in California after being side swiped and over correcting. Three people in the car, one laying in the back seat without a seat belt and no major injuries. Just cuts from the shattered glass everywhere.
  4. I've got a 97 Legacy Outback that needs an alternator, and I just so happened to have an Extra 92 Legacy Alternator. The positive plug ins are different but everything else matches up so I'm going out on a limb and assuming the 92 Alternator will work for the 97. Is there a way to make these plugs compatible?
  5. Just an update, I swapped stereos and fuses. Still nothing. It seems to me I'm not power to the radio. I just have no clue what can cause that besides a bad fuse or bad stereo.
  6. So I just picked up a 97 Legacy Outback with 130k for $3000. It had the stock radio in it until one day I took it out to hook up a sub and amp. When I took the stereo out I tore 2 wires on accident. A yellow wire and a green and white wire. I connected them and put the radio back in seeing as it isn't compatible with a sub or amp. The radio wasn't working so I checked the fuse and it was blown. I replaced the fuse, still no radio, ensured the wires that tore were connected and they were. Still nothing. Think I fried the radio? Im about to go on a 4 hour road trip in a few days and I want some tunes. Help?
  7. So here's the full story to help you folks out. I pulled up to a light and I went to pull my phone out of my console and bumped my shifter into Neutral. I then pushed the gas, realized it was in nuetral, and put it into drive and nothing. I could push on the gas all i wantes and it would go nowhere. The spedometer and tach move. Its an automatic, 1990 Legacy.
  8. So Northwet, if I do that would it make the car rear wheel drive and would it be possible to drive it to a shop?
  9. Its a 1990 awd wagon. Thats what I thought but even if I had a stripped out axle I would still move since technically there are 3 others.
  10. My legacy wagon won't go into any gear. I can put it in drive and hit the gas and the RPMs will go up, as well as the speedometer, but the car will not move. HELP!?
  11. FIXED! Thank You NorthWet. I'm never letting a hillbilly touch my car again.
  12. Oh no.........That's what he did. How would I go about fixing this mess?
  13. The guy that Put the fluid in filled it to the point of overflow.
×