Jump to content

Search the Community

Showing results for tags '88 GL'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 11 results

  1. -----SKIP TO 2018 POSTS FOR THIS FIX------ Hey everyone curious if you could help me with something I've been pondering for a while concerning my 88 GL. Generally if I am in a high rev range say 3,000 and I let off the throttle the engine breaks really hard. so much so that my body is jolted a bit inside the car. I feel it most in gears 1-3, and less in 4 or 5, but it's happens in every gear. This is my first manual transmission, in other (automatic) cars have driven when you let off the throttle, no matter the speed, you just kind of coast. Is what I am experiencing normal for manuals or GL's or older cars? Is there something i am doing wrong like reving to high and staying in the same gear? Any advise would be valuable to me right now, I feel like I'm doing bad things to the engine and I'm hoping senior dog will last for a long while. Let me know what you're thinking. Thanks
  2. Hey ya'll, I'm talking to a guy right now on a Peugeot message board about picking up some wheels off him and I had a question I couldn't find an answer to through the search bar. (does that thing ever work? I can never find what I'm looking for on there...) The wheels he has are 15" diameter and 6" wide. I'm curious if 1. 15" will fit under a non-lifted 88 GL and 2. if anyone knows if they will line up well and not stick out. I'm having trouble finding backspacing information for the subaru wheels and the peugeot wheels. Here's a pic just so you know what I'm looking at.... Dude told me his are 4x100 bolt pattern in the e-mail, but I think he just doesn't know?? They are coming off a 1986 Peugeot 505 Turbo Wagon. He also said mine should be 4x100....so either he mistyped or is just misinformed right? Any help would be great. Thanks ya'll.
  3. Hey Everyone, So I've been having this issue for a while now. While I'm in neutral, by pushing in the clutch or sitting in neutral the idle will spike to around 3,000 and slowly drop down to around 1,500. I've also been having this issue where upon first starting the car I have to hold down the gas pedal until some gas moves through the system or the car will die. Once it's running for a minute, it generally stays around 1,000-1,500. Not sure if these issues are linked, but I thought it would be good to give a little history of what it has been doing. I did change the intake manifold gaskets about a week ago, but it was doing this before that anyway. Let me know what you think. If anyone can link to another thread if this question has been asked that would be great too. I can never find info using the search bar. this is that it's doing --->
  4. Hey ya'll while taking apart my IAC I partially broke the gasket (it's useable, but super hard and now part of it is missing). I was curious 1) if it's supposed to be a non-flexible plastic or if mine is just really old. 2) Could I use a gasket maker to make a new gasket for it? I'd rather not go through the trouble of ordering a new gasket and waiting around for it to show it. would be awesome to grab some RED RTV and just do it today. Not sure about gasket maker cause I've never used it before. I've been reading on here, but couldn't find any solid info. Let me know what ya think or if gasket maker would be okay which one ya'll could recommend. Also! check out that new prof pic. GAMES GAMES vinyl on the GL now for free via school....
  5. Hey ya'll looking to replace my clutch cable and I'm seeing two different sizes when I look up the part. 33.5" and 36" will both sizes work for the 88 GL? I don't want to take mine off and measure...looks like it's at the end of its life. If anyone knows which size or if either would work lemme know.
  6. Alright here we go again, sorry for all the parts questions recently. Just wanna make sure I'm getting the right stuff and I know you guys know your spoob obviously. So here we go. looking at water pump for the EA82 online and I'm finding two different hub heights. one being.... 4.087" the other 4.320" not sure which to get. I'm thinking the difference in hub heights is either with or w/o AC. I don't have AC so I'm thinking the shorter one, but honestly just a guess and don't wanna get the wrong one. lemme know if ya'll have knowledge on this. ALSO, I'm totally unfamiliar with auto manufactures as they relate to quality. RockAuto has a few to select from.... ACDELCO GATES AIRTEX CARDONE AISIN Delco being most expensive and Gates being least. Anyone have brand preference?
  7. So...I've been noticing this noise coming from the bay when I start the car. it's pretty loud from a cold start then tends to die down once the engine warms up. it kind of cycles between loud and quiet not really sure what's up, but I uploaded a video to youtube so you can get a better idea of the noise i am hearing and where it's coming from. no idea on oil pressure as my gauge is non-functioning and from what I hear are unreliable anyway. Might be time to re-seal the oil pump.... here is the video. cheers, TJ
  8. Hey ya'll just wanted to share a recent upgrade to my 88 GL. Swapped the old air intake for a short RAM. I welded the MAF adaptor plate myself and right now it's held in place (temporarily) by a modified hack saw blade (it was what I had laying around the house). So far I've been really pleased with the results! Getting way more throttle response in 1,2, and 3 (increased acceleration) in 4 it seems a little slower to get up to speed, but not much and 5 seems the same. I haven't noticed any increase or decrease in gas mileage, but I also haven't charted it out and I'm not really concerned. Best part is the acceleration for sure, it used to be so slow to get up to speed, not anymore. It's winter here in MI so I haven't had to deal with venting hot engine air yet....waiting on that for the Summer. I have noticed though that the acceleration is slower once the engine warms up a bit, but still better than it was before. I'll be looking to get a water shield for it soon as well, but we have had some rain recently and I've been driving it around. The engine bay stays dry so I'm not to concerned about hydro lock. If anyone wants me to weld up an adaptor plate for them lemme know!
  9. Hey everyone looks like my hill holder on my 88 GL is leaking from a seal. I was curious if it's possible to replace the seals in these or if it's necessary to just get a new hill holder which is proving difficult to find. I'd rather not remove it and have to route more brake line wanna stay stock unless someone has good reason to persuade me otherwise (open to options). I'm loosing about 2TB of brake fluid every two weeks as it stands now. So yeah....possible to repair this thing? Anyone have any solutions for deleting it and maybe a MC upgrade or maybe that's not necessary? Lemme know what ya'll are thinking. TJ
  10. Hey everyone in the process of replacing the oil pressure sending unit on my 88 GL 4x4, the gauge hasn't worked since I got the car and it's stressing me out a little. Anyway, I have a couple of questions. Planning to post this in the fix it section when everything is finished so others can benefit as well. Is it necessary to drain the oil prior to pulling the sending unit? It looks like the one on the car now is unplugged from the female spade and I'm not sure where to find the wire...ideas? There is a part directly next to the sending unit that is plugged in with a spade can I just move it over to the sending unit (doubt it.....) What's the "normal" gauge reading for oil when this thing is fixed? Thanks everyone any advise is appreciated. After this it's the fuel filter.
  11. Hey everyone my first post on here. I'm in the process of swapping out the alternator in my 88 GL with one from an 88 Maxima got the tip off from this site actually as posted by GeneralDisorder. I have a question I couldn't find the answer to in the original thread from 2009 so I figured I'd post this. If this is better left in the comments of the other thread I can delete this, but I wasn't sure where to post exactly...anyway the long awaited question. The GL alternator has this (I think it's some sort of relay?) thing on the back and I'm wondering if I need to move it over to the Maxima alternator because it doesn't have that part. not sure if it's necessary and it doesn't look like the Maxima alternator has bolts that are long enough to accommodate it, but I figured I would ask. I've attached pictures of the back of both alternators for reference. < OLD ALT with thing < NEW ALT no thing
×