Jump to content

Search the Community

Showing results for tags 'cylinder heads'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 3 results

  1. I have a 1999 Legacy GT with the 2.5L EJ25D (dohc, phase 1) and I want to swap the heads. Now I know that I'll need new 2.2L heads with dual port so I don't need to change my exhaust, and I've read that you need a new timing belt. (Donor car will likely be 1995 Legacy 2.2L) Now here are the issues: - Do I need to use the 2.2 head cam sprockets or can I use the ones from the 2.5? - Besides the previous question, do I need anything else other than the 2.2 belt for the timing system? - The bolt pattern for the 2.5 manifold I have has bolts in a straight line, however the 2.2 heads I've seen (1995 and older) have diagonal bolts. - Can I use the 2.5l head bolts? I have a new set which I will use. 14mm 12 point. - Is the bolt pattern the same? My current one has 6 bolts, 3 on top behind the top cam, and 3 down low behind the bottom cam. - If the donor engine (2.2L) didn't have HG issues should I still get the heads planed by a machine shop? - Should I get new valves seats/guides/valves/springs or is that overdoing it? Pics are here (2.5l head, block and manifold): http://imgur.com/a/ExhsZ
  2. Hello - first Subaru here. Really wanting to lift it a bit, bigger tires, etc. BUT I gotta get it running first. Looks like right now, I need a right side head, the current one has a hole in it just in front of the exhaust port. I've got a lead on one that is 3 hours away, they won't ship it. Anyone got one laying around waiting to get back into a running car? 1989 DL Wagon, non-turbo, SPFI - I'd be interested in both heads if you've got em?
  3. So, ive spent the last 2 weeks either waiting for parts or having to return parts because my local auto parts store always orders the wrong thing. Only to run into problems with the finished project... Here is the run down. Its an EA82 1985 subaru gl station wagon. Recent headgasket failure ( cracked heads ) non existent choke, and possibly a bad starter, and bad breaks. So i recently bought re manufactured heads, and a weber carb, and some shiny new brakes. My subi will be perfect after this! IF i can get it running. Here is what I'm 99% sure of. The cams are timed, the distributor is timed, ( enough to start ) and in correct rotation for TDC ( I have rotated it 180 degrees as i made that mistake and troubleshooted that issue. ) I have gas ( 2.5 psi worth from the fuel line ) I'm 90% sure i have no vacuum leak from the intake. as there is good vacuum there. I have excellent compression on all my heads. ( 120-140 ) So i think i have narrowed it down to spark. Which i have, on all wires but... The only thing i have to suspect is my ignition coil reads a little under spec, and my ignition control module reads as having interference. ( which it shouldn't ) But as i have spark im not sure if that matters. The other fishy thing is that my carb seems to spray alittle gas up through the choke butterfly as it turns over. It is so close to starting its not funny. But it just wont get there. Its just not catching/starting. Please help! I'm at wits end and i need this thing running before the end of the week.
×