Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 6 votes

Retro GL-10 TURBO build


  • Please log in to reply
385 replies to this topic

#276 matts87glsedan

matts87glsedan

    USMB is life!

  • Members
  • 229 posts
  • lumby BC

Posted 30 May 2013 - 10:45 PM

i think you need to give us Franz' ph. number, so we can urge him to get the hell over to your house  :P .  We want results! 



#277 Nico

Nico

    USMB is life!

  • Members
  • 218 posts
  • Hamilton, Ontario, Canada

Posted 31 May 2013 - 10:39 PM

i think you need to give us Franz' ph. number, so we can urge him to get the hell over to your house  :P .  We want results! 

 

 

LOL I sure got some results !  more like a spun rod bearing haha...  give me 2 weeks and will have some numbers. in the mean time I am building ASAP

 

 

 

 

 

 

 

 

 

 

well this thread will never die, its a long long build now, ill let the pictures do the talking ! and let the new build be built ASAP summer is near ! 
 
 
the old:
 
EJ22T Block: still ok
 
Wiseco pistons: fantastic ready for the spare block coming right after the new one ASAP
 
ACL Bearings: perfect and save a EJ22T block ! cant say that for the crank lol
 
Manley Rods: Never again will cheap parts ever touch my hands or come in to my shop !
 
11MM Subaru Oil Pump: First and last time EVER !!!!   10MM #1 OLD SCHOOL FTW !
 
ej20g spec RA R crank: dead for good now
 
 
rod bearing 4 said hell no ! 
 
 
 
 
 
 
 
 
The New: ASAP !  waiting for parts or else I would be done in a day build !. 
 
Wiseco pistons: K601M975  new ones on the way
 
Carrillo Pro-H beam rods: SB-2LTR>-65137S
 
ACL Race bearings: 4B8296HX +5M8297HX  STD size both mains and rods
 
10MM Oil Pump
 
and used EJ22T
 
 
 
 
 
thank the lord my JDM Spec-C heads are still perfect !
 
 
 
 
 
 
and my VW Jetta Recaro seats done !  need to order seat base and rails.
 


#278 matts87glsedan

matts87glsedan

    USMB is life!

  • Members
  • 229 posts
  • lumby BC

Posted 03 June 2013 - 10:37 AM

oh noooo!!  that sucks!  so you think the rod was out of spec? or more the oil pump f'-ed you over?   you drove that motor last summer, correct? but then put more boost to it, and this happened?   sorry so many questions, i want to learn from your misfortune, haha.   oh yeah one more - did you see your oil pressure doing anything weird before it went?

 

seats look awesome btw.  nice touch, matching them to the old school interior.   :)



#279 Numbchux

Numbchux

    EJ conversion addict

  • Members
  • 5,983 posts
  • Duluth, MN

Posted 03 June 2013 - 12:14 PM

That's very strange. The only parts in your shortblock that I would use are the ones that you're blaming for the failure.



#280 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 03 June 2013 - 02:26 PM

_Nico driving_

 

"Vroooom, PShhhh, Vrooooooooooom  PSHHHHH,,   Vrooooooooooooooooommmmmmmmmmm NOOOOOOOOOOOOOOOOOO!"



#281 Nico

Nico

    USMB is life!

  • Members
  • 218 posts
  • Hamilton, Ontario, Canada

Posted 03 June 2013 - 03:46 PM

oh noooo!!  that sucks!  so you think the rod was out of spec? or more the oil pump f'-ed you over?   you drove that motor last summer, correct? but then put more boost to it, and this happened?   sorry so many questions, i want to learn from your misfortune, haha.   oh yeah one more - did you see your oil pressure doing anything weird before it went?

 

seats look awesome btw.  nice touch, matching them to the old school interior.   :)

 

 

That's very strange. The only parts in your shortblock that I would use are the ones that you're blaming for the failure.

 

 

well from last year to this year it seems that my oil pressure was not normal, quiet low. I am looking into what the problem was. so far I checked the rod journals and they seem to be in spec even with the killed #4. ill have to check the rods them self.

 

 

 

there is allot of don'ts that I did in this block which I never should have done. 

 

manley I guess makes good rods just not my cup of tea. i rather use the highest quality part for the job. 

 

the 11mm oem pump was a mistake for sure. my motor came from subaru with the 10mm and thats the one i should have used like all my other running builds to this day

 

another mistake was sticking in a crank from a different subaru block which didnt come from the factory pre assembled like that.

 

 

my motor died on the dyno at only 18 psi. last year on the small turbo I was at 23psi.

 

 

 

 

all in all its a lesson learned and ill be back soon with all the mistakes taken care of in the right way !

 

 

 

_Nico driving_

 

"Vroooom, PShhhh, Vrooooooooooom  PSHHHHH,,   Vrooooooooooooooooommmmmmmmmmm NOOOOOOOOOOOOOOOOOO!"

 

 

lol i wish i could have done that, soon i will get that chance.



#282 Numbchux

Numbchux

    EJ conversion addict

  • Members
  • 5,983 posts
  • Duluth, MN

Posted 03 June 2013 - 04:37 PM

You keep talking about not using cheap parts......but you're using Wiseco pistons.....just sayin.

 

I've also seen many strong-running engines using the 11mm oil pump. I know a couple guys who swear by them.

 

 

 

I think your oil pressure issue was not related to the pump. And your bearing failure either related to the oil pressure issue, or possibly the mis-matched crank (I think the majority of the mis-matched shortblock projects I've seen have ended in catastrophic failure).

 

 

 

 

Just my 2 Cents. I'm sure you'll get it buttoned up and back on the dyno/road soon.



#283 Nico

Nico

    USMB is life!

  • Members
  • 218 posts
  • Hamilton, Ontario, Canada

Posted 03 June 2013 - 06:05 PM

You keep talking about not using cheap parts......but you're using Wiseco pistons.....just sayin.

 

I've also seen many strong-running engines using the 11mm oil pump. I know a couple guys who swear by them.

 

 

 

I think your oil pressure issue was not related to the pump. And your bearing failure either related to the oil pressure issue, or possibly the mis-matched crank (I think the majority of the mis-matched shortblock projects I've seen have ended in catastrophic failure).

 

 

 

 

Just my 2 Cents. I'm sure you'll get it buttoned up and back on the dyno/road soon.

 

 

its comes down to personal preference in the end.

 

i like wiseco pistons, have used them in my ej22t for a long time running with great results. I love that its made in the usa, and not sourced out from china like allot of these parts on the market.

 

 

my ej22t and every jdm turbo motor from 1989 to 2007 use the 10mm pump, In this case ill stick with what subaru has given me. 11mm is not for me at all.

 

 

lots of mixing is not good for sure, it wont happen any more like that in my garage.



#284 mstetka

mstetka

    Newbie

  • Members
  • Pip
  • 2 posts
  • Madison, Ohio

Posted 07 June 2013 - 07:37 PM

I just bought a 1988 Subaru GL-10 Turbo Sedan, 2wd 1.8L motor, it only has 66,735 miles on it. it sat in my buddies garage for 15 years because he wanted to build it up and he never did.



#285 Legourde_Nux

Legourde_Nux

    Advanced Member

  • Members
  • PipPipPip
  • 76 posts
  • Santo Domingo, DR

Posted 07 June 2013 - 08:24 PM

Welcome!!!!!....we got ourselves another proyect?  :popcorn:



#286 Nico

Nico

    USMB is life!

  • Members
  • 218 posts
  • Hamilton, Ontario, Canada

Posted 08 June 2013 - 01:39 AM

I just bought a 1988 Subaru GL-10 Turbo Sedan, 2wd 1.8L motor, it only has 66,735 miles on it. it sat in my buddies garage for 15 years because he wanted to build it up and he never did.

 

sounds very nice cant wait to see it... post up some pics and welcome also !

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

its time to go to War !!! so I am taking all 7 of my EJ22T blocks to get cleaned then put on the self and built one after another !...  no more messing around !
 
this was the Original motor out the Leone ! what I am doing is getting a used crank which I have tons of them.. ill rebuilding this sucker with every single thing reused ! but the 11MM oil pump. stock head studs, new ACL bearings & anything & everything cleaned and Re- used ! I am also using a 400,000kms used 10MM oil pump that I know works on it !!!  
 
I don't care at all if it blows up ! why ??? I all ready have another EJ22T block sitting at the machine shop waiting to get its brand spanking new pistons fitted !
 
The was broken motor ! 
 
 
 
The used parts all going back in again ! i dont care 
 
 
 
 
EJ22T #3 getting ready to strip down ! bottom left.
 
 
 
 
also Just picked up this 40,000km JDM V9 STi EJ207 motor for a extra set of JDM big Flow heads !......  ill have two motors on hand now ready to swap in hrs ! 
 
Any one looking for a mint running Short block let me know !
 
 
 
The JDM tear Down ! 
 
 
 
 
JDM POWER ! 10MM PUMP on the newish V9 STi EJ207 !! every jdm motor below 2007 uses 10MM oil pump !! 
 
 
 
 
 
 
 
Sold the Black GC8 STi Volk Rays TE37 rims !  going with 15' rims.. why tires tires tires, 205/50/15 has EVERYTHING !
 
IRS Motorsport   Made in JAPAN !  Motorsport IRS HOME ...... Thank you Nakahara 
 
wheels ill order once I'm done RC-G4 in Gold.
 


#287 tizzle

tizzle

    Subaru Nut

  • Members
  • 605 posts
  • Bellingham

Posted 08 June 2013 - 01:47 AM

Under any hard cornering when it went out?


Edited by tizzle, 08 June 2013 - 01:58 AM.


#288 Nico

Nico

    USMB is life!

  • Members
  • 218 posts
  • Hamilton, Ontario, Canada

Posted 08 June 2013 - 01:58 AM

Were you under any hard cornering when it went out?

 

 

dyno 18psi      but my pump was week from the very start of the motor build with the 11mm pump 


Edited by Nico, 08 June 2013 - 01:58 AM.


#289 tizzle

tizzle

    Subaru Nut

  • Members
  • 605 posts
  • Bellingham

Posted 08 June 2013 - 11:32 AM

Did you have an oil pressure gauge, or how was your oil pressure. Any cracks in your oil pickup tube? 

I spun a bearing on my Ver2 sti RA about a year and a half ago.  I think it was probably due to different oil I used at the time or oil sloshing to one side of the pan under a hard corner, but could have just been age, The rod bolts are a weakpoint on the EJ20g's.

I put an 11mm pump in during the rebuild. Now you got me worrying about that


Edited by tizzle, 08 June 2013 - 11:36 AM.


#290 Nico

Nico

    USMB is life!

  • Members
  • 218 posts
  • Hamilton, Ontario, Canada

Posted 08 June 2013 - 06:33 PM

Did you have an oil pressure gauge, or how was your oil pressure. Any cracks in your oil pickup tube? 

I spun a bearing on my Ver2 sti RA about a year and a half ago.  I think it was probably due to different oil I used at the time or oil sloshing to one side of the pan under a hard corner, but could have just been age, The rod bolts are a weakpoint on the EJ20g's.

I put an 11mm pump in during the rebuild. Now you got me worrying about that

 

yep i have full stand alone with every sensor pluged in to view in the lap top, i need one of those fancy race dash which is next so i can shut it off right away. oil pick is mint I'm re using it, the one in the pic with the block on the floor.

 

cornering is another problem but mine was not even on the road  which makes me even more pissed, it was a bad pump for sure.

 

just check pressure is good with your set up maybe its ok and mine was a bad one.

 

 

 

 

 

 

 

 

 

 

 

 

 

these are the brand spanking new spare parts for the EJ22T #2 motor which is at the machine shop awaiting the Wiseco pistons, Carrillo Rods, ACL race bearings....
 
 
 
 
 
put my A/C back in for those hot days at the track doing circles around people !!! LOL
 
 
 
I got nice big holes all ready made for me !! 
 
 
 
time to cut this sucker up I had enough of this not cutting business !!  see the black lines.
 
 
 
 
6"inch Thick x 7"inch Tall x 20"inch Long   AiR 2 AiR intercooler is coming !!! no more messing around at the kiddy pool !!


#291 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 10 June 2013 - 08:29 AM

All the lead up to the intercooler and then no pics?  Hack that up Nico, lets see that bad boy in there.



#292 Nico

Nico

    USMB is life!

  • Members
  • 218 posts
  • Hamilton, Ontario, Canada

Posted 12 June 2013 - 09:57 PM

All the lead up to the intercooler and then no pics?  Hack that up Nico, lets see that bad boy in there.

 

 

ill make it nice  :D  !.. its one of those things that needed to be done sooner or later lol

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

inspiration for my front mount intercooler ! 
 
 
 
 
 
 
 
 
 
 
 
 
Bell Intercoolers drawings for my new Air To Air
 
 
 
all most there, everything reused from dead bearing #4.
 
 
 
cleaned up the front with Degreaser, time to plan out the new intercooler set up.
 
 
looks good with out the bumper lol
 


#293 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 13 June 2013 - 08:28 AM

I disagree - gotta keep the sleeper look as much as possible. 



#294 subynut

subynut

    EJ Powa!

  • Gold Subscribers
  • 1,375 posts
  • Sierra Vista, AZ

Posted 13 June 2013 - 10:25 AM

I'm curious why the switch to an air to air intercooler. I thought the air to water intercoolers were a better setup, just costs more? Or is there not enough space for the AWIC radiator, A/C condenser, and the cooling system radiator?



#295 Nico

Nico

    USMB is life!

  • Members
  • 218 posts
  • Hamilton, Ontario, Canada

Posted 16 June 2013 - 02:04 PM

I disagree - gotta keep the sleeper look as much as possible. 

 

 

it will look all right once done, its still a sleeper just not from the front section thats all lol

 

 

 

I'm curious why the switch to an air to air intercooler. I thought the air to water intercoolers were a better setup, just costs more? Or is there not enough space for the AWIC radiator, A/C condenser, and the cooling system radiator?

 

in the end air to air is easy and works the best, AWIC are good but pluming water pumps fittings so on and so on. my Air 2 Air will be less weight and work better for the power ill be making.

 

the set up I made is ok for a daily driver with modest power 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

well its all back together, with A/C !! :)     
 
i am super excited to have A/C back in the car, which means those hot summer days in the rain i can see out the fog windows, on the hwy i can roll up the windows so its nice and quiet in the car driving along.
 
 
 
 

Edited by Nico, 19 June 2013 - 10:48 AM.


#296 AKghandi

AKghandi

    87 GL-10 2" lift 27" tires, 86 GL 2" lift 29"

  • Members
  • 1,056 posts
  • Anchorage, Alaska

Posted 17 June 2013 - 02:33 AM

the pics aren't working for me, anyone else have this issue?



#297 Timoha

Timoha

    New User

  • Members
  • Pip
  • 6 posts
  • Russia Tomsk

Posted 17 June 2013 - 03:21 AM

the pics aren't working for me, anyone else have this issue?

yes :(



#298 Nico

Nico

    USMB is life!

  • Members
  • 218 posts
  • Hamilton, Ontario, Canada

Posted 19 June 2013 - 10:49 AM

the pics aren't working for me, anyone else have this issue?

 

 

yes :(

 

 

my bad i forgot not to use photobucket



#299 Nico

Nico

    USMB is life!

  • Members
  • 218 posts
  • Hamilton, Ontario, Canada

Posted 25 June 2013 - 10:15 PM

one invented bracket later ( thanks to Vin@NVauto for welding me the brackets)
 
Alfa Romeo dual lock Sliders ( parts my dad likes to keep from the 1960's lol)
 
one down next one to go while i wait for the intercooler that is on its way for tomorrow.
 
 
Recaro VW Jetta gli seats (Franz idea put into action)
 


#300 Crazyeights

Crazyeights

    Subaru Nut

  • Members
  • 879 posts
  • PNW

Posted 25 June 2013 - 10:56 PM

:slobber:






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users