Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

RX turns 300,000


  • Please log in to reply
15 replies to this topic

#1 All_talk

All_talk

    1000+ Super USER!

  • Members
  • 1,093 posts
  • Thorp (Ellensburg)

Posted 01 June 2005 - 08:16 PM

On the drive home today... :banana::banana:

Posted Image

I bought the car about 14 months ago with 251,000 miles, been using it for my daily for less than a year. It has (and is) serving me quite well, a bit of an oil leak, and some HVA tick once in a while but a strong runner, even did a rallycross in it. Funest car I've ever driven, not bad for $500 bucks.:D

I wanted to snap the pic at 100mph (had to get the needle out from in front of the odometer anyway :D ), but it rolled over up on the pass heading into one of the shaper corners so 90 something was all I felt comfortable with. But have no fear, I wound it up to 100mph a little further down the road where it was safe just to prove old Subies can still haul a$$

I figured it was worth a post and a dancing banana or two.

Gary

P.S. dont mind my silly oil gauge, the sender's goofy, I've checked it with a mechanical gauge and my pressure is fine.

#2 gotime242

gotime242

    USMB Regular

  • Members
  • PipPipPip
  • 81 posts
  • Fort Myers

Posted 01 June 2005 - 08:18 PM

Thats awsome man! Congrats!

Nice green light too :)

#3 75subie

75subie

    I`m sold on Subaru

  • Members
  • 3,908 posts
  • Walden

Posted 01 June 2005 - 08:20 PM

what can i say, thats subaru quality for ya:lol:

did you ever run it flat out?what can these do?(speed)

#4 erik litchy

erik litchy

    Leadfoot

  • Members
  • 1,090 posts
  • Peoria IL

Posted 01 June 2005 - 08:28 PM

makes me wish i could drive mine.

#5 TheBrian

TheBrian

    Eat, Live, Breath Subaru

  • Members
  • 270 posts
  • Buffalo

Posted 01 June 2005 - 08:59 PM

That's an awesome gauge pod.
Does the turbo light come on at a set rev count, or a certain manifold pressure?

Does the driveline drawing in the middle light up or do anything besides notify you that your car rocks?

And congrats on your mileage.

#6 BobBrumby

BobBrumby

    Subaru Nut

  • Members
  • 583 posts
  • Brisbane, Australia

Posted 01 June 2005 - 09:03 PM

Does the driveline drawing in the middle light up or do anything besides notify you that your car rocks?

ON ea81's it tells u if the doors are open and if the car in is 4hi or 4lo

#7 critical_max

critical_max

    USMB is life!

  • Members
  • 167 posts
  • Eugene, Oregon

Posted 01 June 2005 - 09:17 PM

Nice shot. It's good to know that even the "hot" EA82Ts can make it to 300K with proper care - at that rate my JDM mill should make it to the year 2050 or so with the number of miles I put on it. :D

I too am curious about the high end of these cars, but not that curious about mine yet :rolleyes:

The display in the center of the gauge lights up in at least 2 different colors, if I remember right - one for doors, one for 4WD HI / LO range. These instrument clusters have me scratching my head trying to figure out what else to add. I looked at new Imprezas and you have to spec the oil pressure gauge as an option, it sits outside the main instrument area on the dash!

#8 All_talk

All_talk

    1000+ Super USER!

  • Members
  • 1,093 posts
  • Thorp (Ellensburg)

Posted 01 June 2005 - 09:23 PM

Yeah, the EA cars have a better dash/gauge layout than my Legacys, I like having full gauges and there is no good way to add them in the Legs.

Thw turbo light comes on at any boost (above 0psi) and the center diplay shows all sorts of pretty lights (it was the '80s after all), doors, high beams, low range, and diff lock, what all it shows depends on the car and options. I should go take a pick with it all lit up.

75subie, I haven't really strung it out, but it gets up to 95mph or so pretty quick, over 100 takes a little bit. I'd bet it would top out in the 115-120mph range on flat ground with no wind.

Gary

#9 75subie

75subie

    I`m sold on Subaru

  • Members
  • 3,908 posts
  • Walden

Posted 01 June 2005 - 09:25 PM

115 really not bad at all for a $500 soob.i would hate to wreck it at that speed though:-\

#10 Flowmastered87GL

Flowmastered87GL

    WCSS Drunk

  • Members
  • 6,115 posts
  • Portland, Oregon

Posted 02 June 2005 - 12:10 AM

Hmmm 2 interesting things:

#1 Under boost the temp is still pretty darn low

#2 The oil pressure seems lower than in what most of my cars are. Then again I run 20W50 and you probably run 10W30?

Nice to see 300 K Welcome to the club :drunk: (I have 318K)

#11 JWX

JWX

    Lonely driver

  • Members
  • 3,073 posts
  • Atlanta

Posted 02 June 2005 - 12:14 AM

that temp is low? I was going to say that looks a little high to me, and he has a funky sender for the oil press. so it reads low. and ya I have to agree 95 comes quick but after thats its a slow climb, and i always chicken out when I get to 105 :(

#12 All_talk

All_talk

    1000+ Super USER!

  • Members
  • 1,093 posts
  • Thorp (Ellensburg)

Posted 02 June 2005 - 12:33 AM

Some dash pics just for fun.

Posted Image

Posted Image

I'm running a 180deg thermostat and since I put in the new double core radiator it rarely moves off that, I can get it to mid gauge (about 192deg) with long boost runs up the pass (2-5 psi for about 4 miles), and long boost with the A/C maxed with bring it to about 2/3 on the gauge. But that was before I put the mechanical clutch fan back on.

And yeah, my oil sender is messed, it checks out fine with a mechanical gauge, about 45psi at 3500rpm (75mph). Running 10W40 and over due for a change.

I've only had it just over 100mph, and only about 3 times, I typically drive no more than 5mph over the limit.

Gary

#13 Flowmastered87GL

Flowmastered87GL

    WCSS Drunk

  • Members
  • 6,115 posts
  • Portland, Oregon

Posted 02 June 2005 - 12:38 AM

ahhh the 180 stat explains alot of it... I used to run one of those.


Same with the oil, thinner than my oil and needs to be changed, I notice my readings change alot when I change the oil

#14 Myxalplyx

Myxalplyx

    Old Wise and Dumb

  • Members
  • 1,834 posts
  • New Castle

Posted 02 June 2005 - 09:43 AM

This is awesome All_Talk! Congrats!

I was a little concerned about the oil pressure as well until I read through the whole thread.

#15 JaySun

JaySun

    New User

  • Members
  • PipPip
  • 17 posts
  • pensacola

Posted 20 July 2005 - 10:48 PM

90 Legacy Wgn 2WD has 275k, all original miles. most of its life it was used in the mtns of TN and WV as a paddlin' wagon. now just a daily driver. my mom always busts on me about how "beat" it looks. she had to put her brand new car in the shop and i let her borrow mine to get groceries, etc. she brought it back and was like: "that little car can get up and go. i spun the tires leaving the red light and blew everyone away." i just laughed and told her she should've gotten a soobe!:grin: i have a friend who has an older wagon (not sure of the year) that has rolled over and has 50K+ on it now. he parked it in his garage in TN and went to Colorado for a year, flew down this spring, put a battery in it, changed the oil and drove back to aspen. now it's his daily driver.

#16 TheSubaruJunkie

TheSubaruJunkie

    I'M BAAAAAACK!

  • Members
  • 1,921 posts
  • Sacramento

Posted 20 July 2005 - 11:24 PM

I missed this post Gary, gratz on the 300k RX. Mine hit 165k on the trip to WCSS and 166k on the way back. Still a baby in comparison i guess.

Oh, and i like where your boost gauge is installed :)

-Brian




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users