Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 6 votes

What Have You Done to your Soobie lately? (Please post in here and keep it going)


  • Please log in to reply
7265 replies to this topic

#2001 obk25xt

obk25xt

    Subaru Fanatic!

  • Members
  • 570 posts
  • La Center, WA

Posted 08 January 2011 - 08:34 AM

^^^^^ Is that a 110v electric heater where your stereo is supposed go?!?

#2002 WASHroad

WASHroad

    USMB is life!

  • Members
  • 145 posts
  • Lynnwood

Posted 09 January 2011 - 12:25 AM

Made and installed a 2" block lift. 88' GL
Posted Image

Posted Image

#2003 Naegling

Naegling

    New User

  • Members
  • PipPip
  • 12 posts
  • Sweet Home

Posted 09 January 2011 - 07:25 PM

Replaced my muffler last week. Going to get new tires and a set of Jackman's tomorrow.

#2004 T'subaru

T'subaru

    Gone but not forgotten

  • Members
  • 443 posts
  • T'sunami Coast WA

Posted 09 January 2011 - 09:07 PM

Today I did a 5 hour round trip drive to pick up a used alternator for my xt6, a recently aquired rebuilt failed saturday night. I think ill be packing spare parts now

#2005 xman

xman

    USMB Regular

  • Members
  • PipPipPip
  • 77 posts
  • Laguna Niguel, CA

Posted 09 January 2011 - 10:01 PM

Put a properly rebuilt Hitachi on the Brat, hooked up the lines and fired it up. Adjusted the idle and took it for a ride. Runs great, smooth and good power. Doesn't seem rich, should pass smog, fingers crossed. A positive day with the ole Brat for a change.

#2006 beataru

beataru

    Subarus Catch on fire?!

  • Members
  • 1,203 posts
  • Phoenix

Posted 09 January 2011 - 10:27 PM

I walked out into the garage and looked at it. Then walked back inside.

#2007 987687

987687

    Rally Suby!

  • Members
  • 4,232 posts
  • Northern Maine

Posted 09 January 2011 - 10:36 PM

Put a tank of gas and half a quart of oil in it. Good for another few hundred miles.

#2008 Logan K

Logan K

    USMB Regular

  • Members
  • 158 posts
  • Edmonds

Posted 09 January 2011 - 10:42 PM

Made and installed a 2" block lift. 88' GL
Posted Image

Posted Image


Hey WASHroad, do you live in the edmonds-lynnwood area? saw your car drive thru a few months back.

#2009 WASHroad

WASHroad

    USMB is life!

  • Members
  • 145 posts
  • Lynnwood

Posted 10 January 2011 - 03:49 PM

Hey WASHroad, do you live in the edmonds-lynnwood area? saw your car drive thru a few months back.

Yep, up by martha lake, just north of 164th.

#2010 PA-Brat

PA-Brat

    New User

  • Members
  • Pip
  • 8 posts
  • Port Angeles

Posted 10 January 2011 - 06:16 PM

^^^^^ Is that a 110v electric heater where your stereo is supposed go?!?


Yup! Works great too. Haven't got around to pulling the heater core or flushing it out to get a little heat. Just enough out of the stock heater to barely defrost the window.

#2011 PA-Brat

PA-Brat

    New User

  • Members
  • Pip
  • 8 posts
  • Port Angeles

Posted 10 January 2011 - 06:19 PM

Yup. Works great too. Crappy radio reception in the sticks anyway!

#2012 katienadine

katienadine

    New User

  • Members
  • PipPip
  • 18 posts
  • Greenwater

Posted 10 January 2011 - 11:07 PM

Got the crank assembled for my ea81 project :brow: wish I had more time today but, have to sleep sometimes.

Cheers

#2013 mcbrat

mcbrat

    Brattitude Adjustment

  • Administrator
  • 11,185 posts
  • Central Iowa

Posted 11 January 2011 - 11:07 AM

Grizz: fixed my sagging/cracked torsion tube/camber issue, and changed out both fuel filters.

Grizz II: got some 36x12.50x17 Swamper TSL SX tires for it :brow:

#2014 ghost

ghost

    USMB Regular

  • Members
  • PipPipPip
  • 88 posts
  • Danville

Posted 11 January 2011 - 01:08 PM

My new rear wagon lift supports are the wrong ones i think :banghead:

They gave me Mighty Lift d95720. They have the right end for one but for the other thay have a ball type seating... Anyone else have this issue? Let me check the Autozone website to see if it was the right part number.

http://www.autozone....3508_3214_1791_

Well what the hell. They SAY its the right part number, but i dont see how they'll work...

Edited by ghost, 11 January 2011 - 01:10 PM.


#2015 mcbrat

mcbrat

    Brattitude Adjustment

  • Administrator
  • 11,185 posts
  • Central Iowa

Posted 11 January 2011 - 03:43 PM

My new rear wagon lift supports are the wrong ones i think :banghead:

They gave me Mighty Lift d95720. They have the right end for one but for the other thay have a ball type seating... Anyone else have this issue? Let me check the Autozone website to see if it was the right part number.

http://www.autozone....3508_3214_1791_

Well what the hell. They SAY its the right part number, but i dont see how they'll work...


I got a set once that I either had to take off a mount pice, or a reused one of the stock ends....

#2016 deepbluehawaii

deepbluehawaii

    New User

  • Members
  • Pip
  • 3 posts
  • kailua

Posted 11 January 2011 - 04:07 PM

I have a 99 legacy wagon , the timing belt blew out,i have read 97-99 2.2 are interference motors i have a good 93 or 94 motor 2.2 on shelve can i use that non interference motor to replace into 99 wagon?

#2017 987687

987687

    Rally Suby!

  • Members
  • 4,232 posts
  • Northern Maine

Posted 11 January 2011 - 04:11 PM

I have a 99 legacy wagon , the timing belt blew out,i have read 97-99 2.2 are interference motors i have a good 93 or 94 motor 2.2 on shelve can i use that non interference motor to replace into 99 wagon?


You have a phase2 engine, and can't swap your old ej22 in.
There's a chance though it didn't bend valves, I know someone with a 99 that survived a broken belt.

#2018 beataru

beataru

    Subarus Catch on fire?!

  • Members
  • 1,203 posts
  • Phoenix

Posted 11 January 2011 - 04:28 PM

Time for bigger cams, and a sweet head job?

#2019 ghost

ghost

    USMB Regular

  • Members
  • PipPipPip
  • 88 posts
  • Danville

Posted 11 January 2011 - 04:41 PM

I got a set once that I either had to take off a mount pice, or a reused one of the stock ends....


That doesnt seem to be the case with this. It had a ball socket end for one side that cant be removed and theres not a ball in sight for it to attached too.

:(

#2020 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 7,079 posts
  • Waukesha, WI

Posted 11 January 2011 - 06:08 PM

Look for a '95 EJ22. It'll be Duel-port and won't be Interference.

You have a phase2 engine, and can't swap your old ej22 in.
There's a chance though it didn't bend valves, I know someone with a 99 that survived a broken belt.



#2021 987687

987687

    Rally Suby!

  • Members
  • 4,232 posts
  • Northern Maine

Posted 11 January 2011 - 06:11 PM

Look for a '95 EJ22. It'll be Duel-port and won't be Interference.


His is a 99 though. Which means it's a phase2 ej22. Just like the phase 2 ej25 it has a MAP, different wiring, etc. The intake (I've been told) from a phase2 ej22 won't bolt to a phase1 one. I'd love it if it would... but that's how it be.

#2022 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 7,079 posts
  • Waukesha, WI

Posted 11 January 2011 - 06:14 PM

Hmm, interesting. I will have to look into that. From what I have seen on 2nd Gen Legacys in the Junkyard, the plugs and bellhousing looks the same, only thing I seen a being a little different is the Air intake styling, but the sensors look to be in the same place. Anyone else have some info about this?

-Tom

His is a 99 though. Which means it's a phase2 ej22. Just like the phase 2 ej25 it has a MAP, different wiring, etc. The intake (I've been told) from a phase2 ej22 won't bolt to a phase1 one. I'd love it if it would... but that's how it be.



#2023 987687

987687

    Rally Suby!

  • Members
  • 4,232 posts
  • Northern Maine

Posted 11 January 2011 - 06:26 PM

Somewhere in 98 they changed to the phase2 ej22. Some 97 imprezas may have been phase2, I don't really know... But I do know the 99 Legacy has a phase2 in it.

#2024 4wdandme

4wdandme

    New User

  • Members
  • Pip
  • 6 posts
  • bend

Posted 11 January 2011 - 08:24 PM

Im new on here and thought this would be a good place to start. bought a 90 loyale N/A about a month ago. i put a big rump roast roof rack on it, gl-10 seats, new bumper, gl-10 rear wind deflector, speakers and stereo, this week the gl-10 rear disks are going on along with the cb radio install. Posted Image

#2025 TheLoyale

TheLoyale

    Safariwagon: The Legend

  • Members
  • 7,079 posts
  • Waukesha, WI

Posted 11 January 2011 - 10:16 PM

Looking right and proper there! I like the large square light in the center!

-Tom




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users