Jump to content

Search the Community

Showing results for tags 'liberty'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 8 results

  1. G'day everybody, First I'd just like to say , Great site, I have visited a couple of times over the past few weeks and found some really good info and advice from members helping others throughout these posts. Ok, so how did I get here. Well about a month ago I raced to an advertised 1998 Outback wagon, the pics showed quite a tidy car at about 1/3 to 1/4 of potential market value but the ad read that the owner thought it may have a blocked radiator. As soon as I arrive he comes out with the keys and then says he'd just come out to start it before I got there but it wouldn't start, he didn't know why and I sensed he was starting to play Possum and saying maybe because he'd reversed it onto the lawn where it was parked, slight incline nose down and wasn't sure where the fuel pickup was located as a possible reason for not starting. As I looked over the rest of the car he said it was running earlier that day, as he was flushing radiator and added fresh coolant, and apparently drove it to its current position. Supposedly it had overheated about a week prior but monitored since then and only just temp higher than normal but not critical. So one mans trash comes a Pir8s Treasure even though I knew he was playing possum and new more about it than he was making out, I was confident that I will be able to get it running still well under market value and end up with a good vehicle. Now I will continue in another forum and let you know where its at and put the feelers out for some of that good advice I mentioned earlier
  2. Hi Guys, I have a 1990 Liberty that's just started having an odd problem. The high beam light on the dash (that little blue one) has seemingly stopped working. Nothing has recently been installed, or changed. The high beams still work and nothing else dims or stops working. I can't seem to figure out whats happened to it. There also doesn't seem to be a light specifically for it on the back of the cluster? Hopefully somebody will know or have ideas of where to look?? Thanks in advance for any suggestions!
  3. Hi, I'm wanting to put power steering in my Brumby. It will have an EJ with EJ P/S pump. My major question is does the Legacy rack have less travel (turning circle) than the EA82 rack? I know the EA82 racks are very much like the EA81 racks for allowing sharper turning circles but the 2000 model Outback rack is very limited with turning circle.. Thanks, Phiz
  4. Hey all, Just wondering what the possibilities are regarding swapping an 09 xt forester 2.5l turbo into say an older ( **** - 2008) forester, liberty, outback, wrx etc? any quid pro quos or pitfalls that would make it overly difficult?
  5. I have a 1991 Subaru Liberty which was owned by my Great Aunt from new. Its first fuel pump lasted about 19 years. We have had the car since 2009 and it has had 4 fuel pumps in that time, now requiring its 5th. I've used original and non-original parts and nothing seems to make any difference. Between 12 and 16 months the fuel pump stops working. The car does approximately 4000kms a year and has done 137,000 in total. Does anyone have any idea what could be the problem? One faulty fuel pump I could understand. But I cannot understand 5. This is my first ever post on any type of forum so I apologise if I've posted in the wrong area or done something else that's incorrect. Many thanks. Zara
  6. Anyone experienced similar issues, Please help?! She's a 92 Liberty GX AWD Auto wagon, EJ22. After sitting overnight, If I start and run motor on a short trip, like around corner from home to filling station, and switch her off before reaching normal operating temp, she then refuses to fire up again for about 20mins or so! Engine rotates but won't fire up! Half hour later when she does fire up, she puffs out a small smokey bluish cloud, like she's clearing her throat or something! Anyone have suggestions or similar experience to share??
  7. G'day from Australia! Looking forward to diving into these forums and exchanging ideas and advice! I just have to get used to everyone referring to my car as a Legacy, cause in Australia it's called a Liberty! From what I've read already it seems like the collective Subaru Knowledge and experience here could surpass that of the factory! lol...
  8. Hi folks, this is my first post/topic, and I'm happy to find this great forum. We live in Northcote, Victoria. We own a great old 1993 Liberty AWD Station-wagon, and it suits our needs perfectly. In recent years the rear suspension has intermittantly failed...sometimes re-inflating after long drives. There is a control panel near the steering wheel, EP - S Height Control, that has flashed and blinked and sometimes has arrows going in both directions at times. Not sure if the problem is electrical or mechanical. The problem now is unbearable, and we would rather repair than throw the vehicle away. Can anyone suggest a cause, perhaps recommend a strategy, even direct us to an expert...any help would be much appreciated. Thanks in advance. Reidy
×