Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 6 votes

What Have You Done to your Soobie lately? (Please post in here and keep it going)


  • Please log in to reply
7245 replies to this topic

#7226 Starlite

Starlite

    Advanced Member

  • Members
  • PipPipPip
  • 92 posts
  • sweden

Posted 01 June 2017 - 04:18 PM

This!

20170601-204447.jpg

20170601-204458.jpg

#7227 Gloyale

Gloyale

    It's a sickness

  • Members
  • 10,340 posts
  • Corvallis, OR PNW

Posted 01 June 2017 - 07:47 PM

This!

20170601-204447.jpg

20170601-204458.jpg

 

Tap for US standard 7/16 head stud.  Leaves more meat for a Helicoil later should it strip again.



#7228 Starlite

Starlite

    Advanced Member

  • Members
  • PipPipPip
  • 92 posts
  • sweden

Posted 02 June 2017 - 08:21 AM

Nah i will use a M10x1.5 helicoil.

#7229 Starlite

Starlite

    Advanced Member

  • Members
  • PipPipPip
  • 92 posts
  • sweden

Posted 14 June 2017 - 01:06 AM

And this....

20170613-191037.jpg

#7230 KiwiBrumby

KiwiBrumby

    Member

  • Members
  • PipPip
  • 24 posts
  • Balclutha Otago

Posted 14 June 2017 - 03:36 AM

Hi-tech repair on the Brumby today - opened the points gap so that it wouldn't die at the stop-lights or miss on the highway.

(Probably should have replaced them but hey...)



#7231 DaBrizat

DaBrizat

    USMB Regular

  • Members
  • PipPipPip
  • 91 posts
  • Madison

Posted 14 June 2017 - 10:58 AM

I visited the body shop today, and got some disappointing news that my existing bumper would be hard to straighten, and the used and referbbed one I bought not a correct replacement. It would require about as much work to modify as to fix the original. So I'm going to keep looking for a replacement.

On the positive side, they had a window guy there to out the used, chipped windshield back in. And he knew new ones were still available, and the shop gave it to me at cost (It pays to be there when they're working I guess).

So they're putting the brightwork back on and getting it back together. I'm expecting probably in May still, but I'm not pressing them on time. I had negotiated to get it done over slow winter to get discount on labor. I'm getting excited.



#7232 DaBrizat

DaBrizat

    USMB Regular

  • Members
  • PipPipPip
  • 91 posts
  • Madison

Posted 14 June 2017 - 10:58 AM

Oops

Edited by DaBrizat, 14 June 2017 - 11:01 AM.


#7233 Len Dawg

Len Dawg

    New User

  • Members
  • 212 posts
  • Portland,Oregon

Posted 15 June 2017 - 10:27 AM

Put my timing case covers back on... thinking that it's just better to be safe than stuck if one of those Dry Summertime plastic bags cruising the highway get sucked up into my timing belts... because they are no longer stuck to the road, They have Risin!! They are aliiive!! Lol!

Edited by Len Dawg, 15 June 2017 - 10:29 AM.


#7234 russellthehippo

russellthehippo

    Member

  • Members
  • PipPip
  • 12 posts
  • Moscow, ID PNW

Posted 21 June 2017 - 08:29 PM

Bought my first car, and it's a Subaru! 1993 Loyale wagon with 4WD and the 5spd. Only 116,000 miles, in beautiful condition, for only $1,500. First thing I did was drive it up a mountain on rough, muddy old logging roads, the 4WD works like a dream even with stock 13 inch all-seasons. 

 

Proceeded to take it home and rip out the ancient rotting speakers and the cassette/radio head unit. 

I have big plans to turn this into my next adventuremobile and hope to get to at least 250,000 miles with regular TLC, or at least until autonomous electric vehicles render these fabulous cars functionally obsolete.

 

Some pics: 

ew6PfgB.jpg

 

6fBcU5J.jpg

 

5UTzdpE.jpg

 

v2zqxYh.jpg

 

iyOTnks.jpg

 

yam84mO.jpg

 

.

.

.

.

.

So yeah, I'm pretty excited and like I said, I have big plans for it and hope to keep it around for as long as possible. 

Cheers!



#7235 Len Dawg

Len Dawg

    New User

  • Members
  • 212 posts
  • Portland,Oregon

Posted 22 June 2017 - 08:33 PM

Fantastic!!

#7236 iceageg

iceageg

    USMB Regular

  • Members
  • PipPipPip
  • 122 posts
  • Denver, CO

Posted 09 September 2017 - 02:09 PM

Installed the rebuilt engine with new clutch last night.  This morning I tossed in the battery, fluids and started her up.  Ruby Sue is back on the road!



#7237 Al Zhiemer

Al Zhiemer

    Member

  • Members
  • PipPip
  • 16 posts
  • Southside Queensland

Posted 09 September 2017 - 10:43 PM

Wired up front fog lights and roof lights.

Mounted 6.5" Rockford Fosgate speakers behind the seat.

Made up new battery leads and terminals and generally tidied up the wiring loom in the engine bay.

Ordered new headlights and started to build a new wiring loom for them.

Installed central locking and power windows.

In the process of making new upper door trims.

And washed the poor old girl for the first time since I've owned it. Think that's about it for this last week.

#7238 1 Lucky Texan

1 Lucky Texan

    I read a lot about Subarus. '03H6OBW,'06WRX

  • Members
  • 7,585 posts
  • Texas

Posted 09 September 2017 - 11:04 PM

the WRX failed its inspection - for burned-out license plate lights. I never see it from behind at night, actually, I rarely drive it at night - probably a good thing. Cops love to pul folks over for 'dim' plate lights - usually it's older cars and they get a chance to find expired license, no insurance card, maybe smell pot or alcohol, check for warrants, etc.

 

I had some LED wedge bulbs at home from buying some when a front marker light went out so, slapped them in.

 

Need to check-over the outback tomorrow, prep for a trip to CoSpgs.



#7239 subnz

subnz

    USMB is life!

  • Members
  • 204 posts
  • Glenorchy New Zealand

Posted 10 September 2017 - 02:30 AM

My 30 year old Brat has been neglected by sitting for 6 months in car port without being run.

So felt guilty and charged up battery (previously disconnected),

took air cleaner off thinking the worst, 

kicked down the accelerator 10x times, full choke (manual - best , standard hitachi)

and it started instantaneously after a second of turning the key. (stale fuel and all - did top it up with a gallon of fresh fuel)

 

Was almost shocked, surprised coz wasn't expecting it was going to be  that easy.

Gave it a good clean while warming up  and did the garden green waste run and a good run for 30 minutes plus on the road .

 

What made it easier was that it was a 15 C  (60 F) early spring day then last week.

Now colder with snow 4" over last 2 days  35 - 45 F 


Edited by subnz, 10 September 2017 - 02:46 AM.


#7240 kmpdx

kmpdx

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • Portland, OR

Posted 14 September 2017 - 01:30 AM

I installed keyless entry on my 1991 Loyale.

Not too hard, right? Wrong. Holy crap. What a pain, but I did it.

 

The driver door was already modded with a disconnected aftermarket actuator that need a lot of positional adjustment to work.

 

Then I installed this: 

https://www.amazon.c...=keyless entry

 

Which could not work the lock on its own so I had to modify it with this:

 

https://www.the12vol...ity_act_pos.gif

 

Finally, I had to build a bracket and fit the whole thing in the lower hole of the door. It really took me like 10 months to get this all done. Finally have keyless entry in the Loyale!



#7241 kmpdx

kmpdx

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts
  • Portland, OR

Posted 14 September 2017 - 01:30 AM

I installed keyless entry on my 1991 Loyale.

Not too hard, right? Wrong. Holy crap. What a pain, but I did it.

 

The driver door was already modded with a disconnected aftermarket actuator that need a lot of positional adjustment to work.

 

Then I installed this: 

https://www.amazon.c...=keyless entry

 

Which could not work the lock on its own so I had to modify it with this:

 

https://www.the12vol...ity_act_pos.gif

 

Finally, I had to build a bracket and fit the whole thing in the lower hole of the door. It really took me like 10 months to get this all done. Finally have keyless entry in the Loyale!



#7242 iceageg

iceageg

    USMB Regular

  • Members
  • PipPipPip
  • 122 posts
  • Denver, CO

Posted 20 September 2017 - 07:57 AM

Weber is on the car and the craptashi is on the shelf.  Had to make some changes to everything I found written here to maintain Colorado compliant emissions rules but it started right up.  43° morning today and it cold started instantly.  After two short trips she runs perfect.  The idle is a bit high once it warms up but a little tuning was expected.  Combined with the Delta cam and shaved heads it has GOBS more power.  We're talking 0-60 times down from 16 seconds to maybe as low as 13!!!  Seriously though, the additional torque between 1500-3000 is substantial and should make for a much more pleasant daily driver in traffic.



#7243 subnz

subnz

    USMB is life!

  • Members
  • 204 posts
  • Glenorchy New Zealand

Posted 23 September 2017 - 12:20 AM

Weber is on the car and the craptashi is on the shelf.  Had to make some changes to everything I found written here to maintain Colorado compliant emissions rules but it started right up.  43° morning today and it cold started instantly.  After two short trips she runs perfect.  The idle is a bit high once it warms up but a little tuning was expected.  Combined with the Delta cam and shaved heads it has GOBS more power.  We're talking 0-60 times down from 16 seconds to maybe as low as 13!!!  Seriously though, the additional torque between 1500-3000 is substantial and should make for a much more pleasant daily driver in traffic.

Never had many issues with  1st 4 Subarus with Hitachi carbs  apart from one on an EA82  I  messed up rekitting / rebuilding so replaced with a 2nd hand one of the same. 

Still have a 30 year old Brat still with its original hitachi carb - hadn't been running for 6 months and it started recently after 1 second of turning the key  (full manual choke and kicked down accelerator 10x times before turning key / cranking engine)



#7244 damnsubaru

damnsubaru

    Advanced Member

  • Members
  • PipPipPip
  • 82 posts
  • pine city washington

Posted 24 September 2017 - 10:54 AM

whats up with photobucket pics would be nice.



#7245 Loyale 2.7 Turbo

Loyale 2.7 Turbo

    The Mighty "BumbleBeast"

  • Members
  • 7,502 posts
  • Roatán, Honduras.

Posted 25 September 2017 - 03:31 AM

whats up with photobucket pics would be nice.

 

~► http://www.ultimates...e-hosting-woes/



#7246 iceageg

iceageg

    USMB Regular

  • Members
  • PipPipPip
  • 122 posts
  • Denver, CO

Posted 25 September 2017 - 07:47 AM

Never had many issues with  1st 4 Subarus with Hitachi carbs  apart from one on an EA82  I  messed up rekitting / rebuilding so replaced with a 2nd hand one of the same. 

Still have a 30 year old Brat still with its original hitachi carb - hadn't been running for 6 months and it started recently after 1 second of turning the key  (full manual choke and kicked down accelerator 10x times before turning key / cranking engine)

The hitachi would start and run at WOT just fine.  Choke would not stay open after the engine had warmed up, accelerator pump not squirting, and i'm pretty sure the secondary did not open.  But it started and ran well enough to get around.  All that said, this is also the first time I have converted to weber.  I have never had a significant problem with my hitachi's in the past.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users