Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 6 votes

What Have You Done to your Soobie lately? (Please post in here and keep it going)


  • Please log in to reply
7287 replies to this topic

#7251 Knucklehead Saloon

Knucklehead Saloon

    USMB is life!

  • Members
  • 195 posts
  • Singleton NSW Australia

Posted 26 October 2017 - 01:30 AM

Hi gang. I've got a 91 Brumby and here's whats been upgraded over the last 4 weeks.

Replaced the batt with a 330cca no maintenance type (Exide brand)
Attached File  batt4.jpg   142.65K   14 downloads

Replaced the fan belts with gates brand belts.
Attached File  belts.jpg   115.91K   14 downloads

Junked the original coil for a 45000v MSD Blaster
Attached File  coil.jpg   147.91K   13 downloads

Dropped in a cardmon reco disty (ND)
Attached File  dizzy.jpg   126.64K   17 downloads

Swapped out the old seized thermostat for a high flow unit
Attached File  thermostat.jpg   126.71K   19 downloads

Checked the water galleries while it was apart and happy to find no traces of stop leak gunk in there
Attached File  intakemanifold.jpg   140.49K   14 downloads

Changed the plugs for NGK Iridiums
Attached File  plugs.jpg   122.97K   12 downloads

Switched the radiator cap from a 13psi to a 15psi unit. Summers are really hot here in Australia
Attached File  radcap.jpg   127.76K   14 downloads

Installed a SAAS tach to the door pillar trim
Attached File  tach.jpg   108.72K   20 downloads

Installed a Nadi sports steering wheel with an SAAS boss kit
Attached File  wheel.jpg   136.53K   26 downloads

Changed out my broken sun visor clips for some a mate 3D printed for me
Attached File  visorclip.jpg   119.93K   29 downloads

Junked the old water pump for a new GMB unit
Attached File  waterpump.jpg   113.18K   43 downloads

In this pic you can see the improved impeller design of the GMB pump
Attached File  waterpump2.jpg   124.34K   37 downloads

More mods and upgrades to come too, just waiting for parts to turn up.
Lovin' my old Scoob-a-roo.

#7252 jmoss5723

jmoss5723

    Subaru Nut

  • Members
  • 578 posts
  • Pittsburgh, PA

Posted 06 November 2017 - 03:33 PM

I removed the muffler from my Forester and got straight pipe welded in. It sounds awesome, but way quieter than I expected. It is completely unobtrusive while cruising around, but gives some growl when you get on the gas hard.



#7253 Knucklehead Saloon

Knucklehead Saloon

    USMB is life!

  • Members
  • 195 posts
  • Singleton NSW Australia

Posted 08 November 2017 - 12:46 AM

Today I sorted out my thermofan crazy running woes. Sometimes they'd work and other times not. If they were running they'd cut out when I turned on the headlights. No idea what kind of dodgy work the previous owner did with the electeics so I decided to run my own fan circuit from scratch.

Grabbed a 40 amp 5 pin relay from the parts store and wired it from a design in my head after sitting and looking at the wiring schomozzle for the time it took to down 2 beers and smoke a cigga. Cut the old wiring out and started anew.

Control circuit side of the relay wiring goes: Original accessories on power wire for fan1 to relay. Relay to thermoswitch in radiator. Thermoswitch (single wire stock unit) closes at temperature and sends power to ground, completing the circuit and energising the power circuit side of the relay.
Attached File  tfan2.jpg   110.25K   20 downloads

Power circuit side of the relay goes: Positive battery to inline fuse (30A), inline fuse to relay, both positive leads from relay to fans, both negative leads from fans to negative battery.
Attached File  tfan1.jpg   161.33K   25 downloads

Took the brumby for a run in the hills near home for 40 minutes and flogged it mercilessly trying to get it to overheat. Temps stayed stable at a bit over halfway on tje gauge. Next mod will be swapping out the stock thermoswitch for a TFS156 that kicks in 10 degrees cooler. The summers get real hot here in inland Australia and I want my Soobie to live long and strong!!

#7254 1 Lucky Texan

1 Lucky Texan

    I read a lot about Subarus. '03H6OBW,'06WRX

  • Members
  • 7,987 posts
  • Texas

Posted 12 November 2017 - 12:13 AM

late doing oil changes on both my cars but today I got the WRX on ramps. changed oil/filter, new wiper blades all round, tightened the clamps ts the fuel line 'buffers' or w'ever they are - last year I smelled fuel in cold weather, looked around/inspected stuff.

 

one weird thing I tried...when I changed strut mounts and struts, I noticed a drain hole (???) on the underside of the starter. It has been making dragging noises for a long time now when temps are under 50* or so. I managed to spray some lithium grease up in there with a tube on the spray can. Dunno yet if it will get even remotely close to the pinion gear's shaft - figured it couldn't really hurt anything. fingers crossed.

 

need to change oil on the OBW



#7255 czny

czny

    USMB is life!

  • Members
  • 449 posts
  • Troy MT

Posted 12 November 2017 - 11:31 AM

Already moved inner axle boot clamps in for 4 inch lift & while this helped prolong boot life, more improvements were still needed. Found suggestions here: http://www.ultimates...es#entry1233972

Dropped engine & trans crossmembers 1 inch to improve front axle angles, modded intake air boot for 1 inch drop, modded skid plate for 1 inch drop, replaced PS pump & high pres hose(leaking from shaft seal), helicoiled adj ear of alternator(stripping), replaced upper & lower radiator hoses modded for 1 inch drop, reworked steering shaft coupler for 1 inch drop(longer). Replaced rad cooling fan(blades were crumbling to dust), LOF too.

 

More yet to do: F&R brakes(rotors & pads), R&R WW motor, replace htr resistor(not all spds), change lube in trans & read diff.

 

Its a long trip to MT & back again, so..........


Edited by czny, 12 November 2017 - 11:38 AM.


#7256 1 Lucky Texan

1 Lucky Texan

    I read a lot about Subarus. '03H6OBW,'06WRX

  • Members
  • 7,987 posts
  • Texas

Posted 12 November 2017 - 03:22 PM

czny - you might investigate axles from HERI, they have more extension.

 

subaru-flyer-yellow.jpg



#7257 1 Lucky Texan

1 Lucky Texan

    I read a lot about Subarus. '03H6OBW,'06WRX

  • Members
  • 7,987 posts
  • Texas

Posted 13 November 2017 - 11:22 AM

not cool enough this morning to 'test' the lithium grease trick in the starter.

I've seen diagrams of the internals and I'm not convinced the spray gets far enough forward.

#7258 czny

czny

    USMB is life!

  • Members
  • 449 posts
  • Troy MT

Posted 14 November 2017 - 04:33 PM

"czny - you might investigate axles from HERI, they have more extension."

 

Thanks 1 Lucky Texan, but axle angles are better, ride is better, ride height is even ft & rr now. Will try 1/8 inch toe out like has worked for me in the past. I get a little wandering at 0 toe in.

My same axles made it to Tucson & back before the 1 inch drop mod so they'll likely live longer now.


Edited by czny, 14 November 2017 - 04:37 PM.


#7259 subynut

subynut

    EJ Powa!

  • Members
  • 1,422 posts
  • Sierra Vista, AZ

Posted 14 November 2017 - 04:52 PM

cznz,

 

Tucson? You live in southern AZ too? I live about an hour south of Tucson near Sierra Vista! :)



#7260 czny

czny

    USMB is life!

  • Members
  • 449 posts
  • Troy MT

Posted 14 November 2017 - 10:29 PM

cznz,

 

Tucson? You live in southern AZ too? I live about an hour south of Tucson near Sierra Vista! :)

No, still live in Azusa CA but travel to my sister's place in E Tucson. Usually stop in Tonopah for lunch.:)



#7261 bbbs53

bbbs53

    Subaru Fanatic!

  • Members
  • 488 posts
  • Sequim, Washington

Posted 26 November 2017 - 03:55 AM

After 6 years of sitting, mine is in the garage for a total restoration. Pulled off the hood and started digging. First off I need to pull the trans and do the clutch and cover etc. Since it has a 5 speed, it will need an EA-82 set. I bought all of the parts years ago and now it is just a matter of getting them installed. Due to being close to the beach in Washington, I have some rusted fasteners, but none in the body. I have a Weber for it and it already has the rear disc brake conversion. Since it is an '82, it has power steering, brakes and air, all of which will be put right. The "third eye" and switch are in and it is getting a "roo bar" I had sent from Australia, all aluminum. I am going to install the 14" Pug rims that now have my studs on them, not necessary at the coast. Most of the expendables are getting done, shocks, brakes, struts, rotors and a new windshield and rubber. About the only thing I haven't found in this mess is the new T-tops I have, somewhere. The old rubber is, well, old rubber. Once the mechanicals are finished it will go back to black with the gold and red stripes. I figure all of this will take the rest of the winter. I scored a new set of bed surround chrome about 10 years back. This is a San Diego truck I bought from a fellow member on here in '03. No rust. I do need to find the EA-82 interior shift cover parts and the steering column covers. I toyed with swapping engines, but after compression checking, no need. The dash has a crack, naturally, and will need some repair, outside of that the interior is fairly nice. After 13 years and a lot of miles before I parked it, it is going to get the treatment it deserves. I did spring the driver door hinges in a minor snow incident when the door came open when it was being pulled out. I have a new top hinge and will make the bottom one work. I am really glad I don't have to find these parts now, seems they are getting hard to come by. Once finished, it probably won't see much use, my Z3 is my daily driver. I am going to do it because one just doesn't see '82's anymore and this one is worthy of the work. I haven't posted in a very long time. I have some fenders and other gen 1 Brat parts and a couple of sets of alloy wheels and a host of gen 2 stuff. Once I am finished, it will all be available. Since I am now retired, I can take my time and do it right. I will start adding pics in a few days. I did restore my last gen 1 I bought in Sumner from Ken and hauled back to Idaho. It now lives in Kansas. It still has the WCSS5 plate from '03 on the glove box. Like me it's a bit faded, but still there. It ran when I shut it down just fine and I suspect it will fire right up. Looking forward to getting her back in shape.


Edited by bbbs53, 26 November 2017 - 04:21 AM.


#7262 1 Lucky Texan

1 Lucky Texan

    I read a lot about Subarus. '03H6OBW,'06WRX

  • Members
  • 7,987 posts
  • Texas

Posted 26 November 2017 - 01:27 PM

not cool enough this morning to 'test' the lithium grease trick in the starter.

I've seen diagrams of the internals and I'm not convinced the spray gets far enough forward.

 

didn't help

 

I might try to get some very small shrink tubing so I can work it farther forward (maybe) and have the can in a less awkward position - still not confident that would work.



#7263 Knucklehead Saloon

Knucklehead Saloon

    USMB is life!

  • Members
  • 195 posts
  • Singleton NSW Australia

Posted 02 December 2017 - 02:07 PM

My brumby got new cvs all round. The fronts are drivetech extra HD.
Attached File  cv2.jpg   225.15K   20 downloads
Attached File  cv4.jpg   199.24K   21 downloads

Rears are reman units from cvjoints australia.
Attached File  rearcv.jpg   322.69K   17 downloads

Edited by Knucklehead Saloon, 02 December 2017 - 02:14 PM.


#7264 Knucklehead Saloon

Knucklehead Saloon

    USMB is life!

  • Members
  • 195 posts
  • Singleton NSW Australia

Posted 02 December 2017 - 02:17 PM

Also got new plates !!

Attached File  plates.jpg   160.92K   34 downloads

#7265 Naked Buell

Naked Buell

    USMB Regular

  • Members
  • 441 posts
  • Evans, WA

Posted 03 December 2017 - 11:21 AM

Man that is a killer front bumper on that Brumby. How about some more pics of your brat Knucklehead. That is a cool name. :)

#7266 Knucklehead Saloon

Knucklehead Saloon

    USMB is life!

  • Members
  • 195 posts
  • Singleton NSW Australia

Posted 05 December 2017 - 11:01 PM

No worries NB. I'll take skoob on a photoshoot in the next week or 2 and post it here.

#7267 Thanatos

Thanatos

    Newbie

  • Members
  • Pip
  • 1 posts
  • Tacoma, WA

Posted 23 January 2018 - 12:28 PM

Howdy everyone, new user here.

I have been digging through these forums for a bit for tips and tricks, and I must say, everything has been very helpful.

So, to begin, I have an '88 GL Wagon D/R 5spd with just a hair over 250k mi on the clock. I purchased it used about a year ago because we had owned another several years ago and these things are hard to kill. Unfortunately, the first one we owned was from New England area and was so rusted I was literally unable to change the brake calipers when they started locking up, so it had to get scrapped (sad, but I didn't have tools or a garage at the time)

 

Well, on to the newest addition to my personal transportation fleet:

 

I managed to find one at the local pick-n-pull, so have mostly stripped it of anything useful and easily carried (CTS, TPS, IACV), plus the rear tailgate lift struts, dash bezel, one rim (for a full-size spare) and a few other odds and ends. 

 

So far since purchasing, I have repaired / replaced the following:

 

Front Half Shafts

Brake Pads / Shoes

Coolant Temp Sensor

Idle Air Control Valve

Rear Hatch Support Struts

Tune up stuff (Plugs, wires, etc.)

New radiator / Hoses

New Timing belts and tensioners (broke while driving - thank GOD for non-interference engines)

 

Still to do is clutch and possibly a few tiny adjustments on the engine.

 

I have to say, this little F%$%er runs like a champ and is about to take a road trip to Colorado from Tacoma, WA

I will see if the junkyards there have any parts to snag while I am in town.

 

Additionally, I managed to convert my side / front marker lights (the white ones at the front corners) into combination marker / turn signals, so the former turn signal lights under the front bumper will become fog light locations.



#7268 Johnnyboy

Johnnyboy

    USMB Regular

  • Members
  • PipPipPip
  • 110 posts
  • Christchurch, New Zealand

Posted 04 February 2018 - 04:22 AM

Fitted LED headlights



#7269 Len Dawg

Len Dawg

    New User

  • Members
  • 246 posts
  • Portland,Oregon

Posted 14 February 2018 - 07:54 PM

1993 Loyale 5spd 4wd Wgn last fall new front rotors and pads yesterday new rear drums and brake shoes.. kinda bent/madd because i gots ta use more brakes now to get front wagon wheels to fit again... apparently I picked up the wrong ones for the snow tires!! Yeah that ought to take another 10yrs to wear down so they fit aAgAiN!! LOL!!

#7270 Eatmore Mudd

Eatmore Mudd

    New User

  • Members
  • PipPip
  • 13 posts
  • 98433

Posted 24 February 2018 - 05:38 PM

Replaced a tail light assembly, door lock cylinder and fixing the blower fan system.

 

Long live the GL.



#7271 kmpdx

kmpdx

    Advanced Member

  • Members
  • PipPipPip
  • 99 posts
  • Portland, OR

Posted 02 March 2018 - 10:16 PM

I finally changed the fuel filter. I was reluctant because the factory hose between the "in" part the screw was turned inside toward the  master cylinder and not really accessible. I bought a ratcheting offset screwdriver which I had to grind like 80%of the bit down to get it short enough to fit in there. I spent at least 1.5 hours getting the f-ing screw and clamp out. But I did it!

 

Turns out the fuel filter that was in there was backward!

 

In the process, I noticed that the longest spark wire (1?) was not in good shape. I bought new NGK wires for less than $22. The motor is runnnig better than ever! I had seriously underestimated the importance of fully functioning spark wires. Changing this wire along along with the rest, fixed my high-idle problem! I had chased it and partially fixed it through a bunch of other crap, but I could never get it to idle below 1000 RPM for the most part. 

 

Fianlly since I bought it it is consistently idling near the correct 700 RPMs.

 

I plan to create a post outlining this since around a year ago there were a few people interested in this exact same thing.



#7272 MR_Loyale

MR_Loyale

    22 Years of Ownership. 94-16

  • Members
  • 1,527 posts
  • Seattle

Posted 05 March 2018 - 07:46 PM

Did another warranty replace of alternator in red sedan. 



#7273 Len Dawg

Len Dawg

    New User

  • Members
  • 246 posts
  • Portland,Oregon

Posted 06 March 2018 - 12:24 AM

Check this..... I have had a drivers side wheel bearing squawking with kinda serious vibration at 55-60mph and a narley familiar bearing r-ree r-ree r-ree.. driving through town, which I know something is going on because I walked outside of my car in a parking lot at work with the motor off coasting and I'll have to go in to pack or replace.

i took the wheel off and rotated to a diffrent lug location and it got 90% better although i think it could be the inside bearing.. yes I'll brag.. it got better but it's faint.

Then -in a RARE episode as i don't beat on my subaru eveyday- today trying to merge a lane in traffic with signal activated to please let me in nobody would give me a shot to get in..so i had nobody behind me and nobody in front in my lane so i slowed back past all those tightwads that wouldn't let me in, I wound up the rpm's up and dumped the clutch and burned the rubbers not just the powerwheel rightside but both, then one of the tight wads decided to pull out and cross in front of me to a side street. So I slammed the brakes and again burnt the tires to get in... yeay!! f$%<× s@#&heads!! I gotnin!! and meanwhile slooowing to a stop at the next light whadya know? No more bearing noise! Not that I would suggest following my remedy but it's my belief that perhaps I spun the bearing?? Lol! Never thought of it... but still I'll have to go in a repack or replace plus i should get a center ring just because perhaps it's just that... who knows right? Lol!

Edited by Len Dawg, 06 March 2018 - 01:09 AM.


#7274 1 Lucky Texan

1 Lucky Texan

    I read a lot about Subarus. '03H6OBW,'06WRX

  • Members
  • 7,987 posts
  • Texas

Posted 06 March 2018 - 08:49 AM

seems more likely you had a stuck caliper and the agressive braking may have freed it up.



#7275 Len Dawg

Len Dawg

    New User

  • Members
  • 246 posts
  • Portland,Oregon

Posted 06 March 2018 - 11:35 PM

Well... spoke too soon it's back!! Kinda... sorta..in a round about way... it's a weird one, left front squeaks when I turn left 😀😁😂🙃🤣😄😅😆🙃😉🙃




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users