Jump to content

Search the Community

Showing results for tags 'mpfi'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 9 results

  1. I have a 1985 4wd Turbo RX manual trans Subaru. I am not sure why I can't get the car over 4k rpm and the turbo light comes on after 3k but kinda flickers, could I get some help understanding why the cars lacks power. I have great idle, easy cold/hot start and trouble with climbing hills and speed above 45 mph.
  2. I'm getting a couple ea81 turbos soon, - one with a bad bottom end, the other is assumed running condition - and I'm considering using the good ea81t in a ea82 wagon with SPFI. I don't have the ecu's or the MPFI wiring. Here's what I'm thinking: -EA81T block w stock turbo cam -EA82T Heads shaved .025", maybe not( I'm aware of the change in valve geometry) -EA82 Pistons(compression bump) -EA82 SPFI (Already in the car) Ok so I've dropped ea81's into ea82 cars before with spfi, but I have no experience with the turbo ea81s. I'm not gonna use the MPFI injectors, but they'll stay to plug the injector holes. Once I get the compression up, my big question is the EA81 cam...will it be worthwhile? Gutless(more gutless than a stock ea81 under ea82 spfi)? I'm not interested in building an ea81 turbo, but I have these parts and I wouldn't mind a running engine. I couldn't find any info in going from ea81 turbo-->ea81 non-turbo w/ spfi or weber, any input is appreciated! TIA Josh
  3. Hi, We have a Swiss Station 1987, EA82 with MPFI and 3 speed AT with ca. 130k km. I replaced the timing belts at 80k km, head gaskets and oil seals a couple years ago, radiator, alternator, some brake lines, brake discs and pads. Generally it's a great car, just getting rusty. It consumes oil at approximately 1L per four tanks of fuel. It has been pinging up steep hills for years; a Subaru garage I left it with said they couldn't reproduce a ping and so it's been left that way. It's recently developed a very slow idle in Drive when the choke turns off. So low, that it dies under load with low throttle, like when you try to reverse slowly. Today the engine suddenly cut out at 80 km/h while cruising on level ground. It cranks over strongly, but we couldn't start it again. I towed it home. I suspected the fuel pump. It makes a buzzing noise when the key is turned to "ACC", but I can't remember what it used to sound like when the car worked?! Apart from taking it out (looks like a rusty mess in there!), is there any way to test it from under the hood (bonnet for you UK readers)? Does the fuel just start flowing out of the tank when you take the pump off? Does anyone have any other suggestions for systematically testing systems to find our problem? Does the idle issue give a clue? I'm fine with old electromechanical cars, but don't have the tools or experience with automotive electronics or fuel injection. Thanks, Jeremy
  4. My son bought a stock 92 Justy with 5spd, 4wd and MPFI. We put a new Cat on it and it seems to run fine. We are only getting 31mpg at 55-60mph. We though it should get more in the range of 38-40mpg. Any ideas?
  5. I've got a set of EA82 turbo heads off of my 1987 GL-10 wagon. Motor lost a rod bearing in the bottom end, but there was no sign of failure from the top end. Includes intake, fuel rails, etc.... Finally did the EJ22 swap after doing one on my Vanagon, so I don't need these goodies anymore! Make me an offer, I was thinking in the neighborhood of $100. I am in the Portland area if you want to pick them up, since the cost of shipping would be atrocious.
  6. Hi all. I set up the O-scope the other day too test a optical disty before shipping it off. Thought I would make a little video to show the process. This particular disty is an 87....that was modified for EA81 use. So it looks a bit odd..... This one had the round plug.....and in 87 the pins are different position on the ECU......so using different year dists can require swapping pins on the body side connector. The wire colors on the distys themselves did not change over the years. <embed width="600" height="361" type="application/x-shockwave-flash" allowFullscreen="true" allowNetworking="all" wmode="transparent" src="http://static.photobucket.com/player.swf" flashvars="file=http%3A%2F%2Fvid209.photobucket.com%2Falbums%2Fbb29%2FGloyale%2FIMG_1042_zps1b8d61b1.mp4&title=">
  7. Oregon Bugaru

    74 VW Super Beetle with Subaru swap

    Picked up this straight body 74 Super Beetle a couple years back for the bugaru project.
  8. so ive been looking into dependability of my ea82t, and was wondering if anyone has ever used the ea82t dual intake mpfi heads for a dual 2 barrel carb set up obviously would require mods to distributor and fuel system, but would it be worth the conversion for the dependability of being carbed instead of turbocharged
  9. I have a 1986 Subaru Leone fitted with a MPFI EA82T. Here the other day the engine kept "dying" shortly after it was fired up After a long session of troubleshooting, I managed to narrow the problem down to the ECM. It seemed though as it didn't manage to give the proper grounding to the fuel pump. I tested this by providing the grounding from the "outside" of the ECM. With this the engine ran smoothly and was on the verge of stopping only when the grounding was removed. So the problem appears to be the ECM which I now have to replace. The spare-ECM comes from a slighly older Leone with a non-turbo MPFI EA82. Some of the partsnumbers on the on the module itself is different.(Check the pictures) But the connectors are all the same. My question then is whether or not it is a smart idea to use the spare-ECM. Any ideas? Turbo ECM Non-Turbo ECM
×